7-8 jmu-Java-03面向对象基础-03-形状

1. 定义长方形类与圆形类Circle

长方形类-类名:Rectangleprivate属性:int width,length
圆形类-类名:Circleprivate属性:int radius

编写构造函数:
带参构造函数:Rectangle(width, length),Circle(radius)

编写方法:
public int getPerimeter(),求周长。
public int getArea(),求面积。
toString方法,使用Eclipse自动生成。

注意:

  1. 计算圆形的面积与周长,使用Math.PI
  2. 求周长和面积时,应先计算出其值(带小数位),然后强制转换为int再返回。

2. main方法

  • 输入2行长与宽,创建两个Rectangle对象放入相应的数组。
  • 输入2行半径,创建两个Circle对象放入相应的数组。
  • 输出1:上面2个数组中的所有对象的周长加总。
  • 输出2:上面2个数组中的所有对象的面积加总。
  • 最后需使用Arrays.deepToString分别输出上面建立的Rectangle数组与Circle数组

思考:如果初次做该题会发现代码冗余严重。使用继承、多态思想可以大幅简化上述代码。

输入样例:

1 2
3 4
7
1

输出样例:

69
170
[Rectangle [width=1, length=2], Rectangle [width=3, length=4]]
[Circle [radius=7], Circle [radius=1]]

代码展示

import java.util.Arrays;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Rectangle[] recArr = new Rectangle[2];
        Scanner sc = new Scanner(System.in);
        int perimeterSum = 0;
        int areaSum = 0;
        for (int i = 0; i < recArr.length; i++) {
            recArr[i] = new Rectangle(sc.nextInt(), sc.nextInt());
            perimeterSum += recArr[i].getPerimeter();
            areaSum += recArr[i].getArea();
        }

        Circle[] cirArr = new Circle[2];
        for (int i = 0; i < cirArr.length; i++) {
            cirArr[i] = new Circle(sc.nextInt());
            perimeterSum += cirArr[i].getPerimeter();
            areaSum += cirArr[i].getArea();
        }

        System.out.println(perimeterSum);
        System.out.println(areaSum);

        String str1 = Arrays.deepToString(recArr);
        String str2 = Arrays.deepToString(cirArr);

        System.out.println(getChange(str1));
        System.out.println(getChange(str2));
    }


    public static String getChange(String str1){
        StringBuilder sb1 = new StringBuilder();
        for (int i = 0; i < str1.length(); i++) {
            char c = str1.charAt(i);
            if (c == '{') {
                sb1.append(" [");
            } else if (c == '}') {
                sb1.append("]");
            } else {
                sb1.append(c);
            }
        }

        return sb1.toString();
    }
}




class Rectangle {
    private int width;
    private int length;

    public int getPerimeter() {
        return 2 * (this.width + this.length);
    }

    public int getArea() {
        return this.width * this.length;
    }

    public Rectangle() {
    }

    public Rectangle(int width, int length) {
        this.width = width;
        this.length = length;
    }

    public int getWidth() {
        return width;
    }

    public void setWidth(int width) {
        this.width = width;
    }

    public int getLength() {
        return length;
    }

    public void setLength(int length) {
        this.length = length;
    }

    @Override
    public String toString() {
        return "Rectangle{" +
                "width=" + width +
                ", length=" + length +
                '}';
    }
}


class Circle {
    private int radius;

    public int getPerimeter() {
        return (int) (2 * this.radius * Math.PI);
    }

    public int getArea() {
        return (int) (this.radius * this.radius * Math.PI);
    }


    public Circle() {
    }

    public Circle(int radius) {
        this.radius = radius;
    }

    public int getRadius() {
        return radius;
    }

    public void setRadius(int radius) {
        this.radius = radius;
    }

    @Override
    public String toString() {
        return "Circle{" +
                "radius=" + radius +
                '}';
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值