- 定义长方形类与圆形类Circle
长方形类-类名:Rectangle,private属性:int width,length
圆形类-类名:Circle,private属性:int radius
编写构造函数:
带参构造函数:Rectangle(width, length),Circle(radius)
编写方法:
public int getPerimeter(),求周长。
public int getArea(),求面积。
toString方法,使用Eclipse自动生成。
注意:
计算圆形的面积与周长,使用Math.PI。
求周长和面积时,应先计算出其值(带小数位),然后强制转换为int再返回。
2. main方法
输入2行长与宽,创建两个Rectangle对象放入相应的数组。
输入2行半径,创建两个Circle对象放入相应的数组。
输出1:上面2个数组中的所有对象的周长加总。
输出2:上面2个数组中的所有对象的面积加总。
最后需使用Arrays.deepToString分别输出上面建立的Rectangle数组与Circle数组
思考:如果初次做该题会发现代码冗余严重。使用继承、多态思想可以大幅简化上述代码。
输入样例
1 2
3 4
7
1
输出样例:
69
170
[Rectangle [width=1, length=2], Rectangle [width=3, length=4]]
[Circle [radius=7], Circle [radius=1]]
这里先说明一下toString方法,使用Eclipse自动生成。
右键选择Source(或者使用快捷键:Alt+Shift+s)后选择Generate toString(),根据需要勾选Fields里的内容(这道题width,length都要选)之后点击右下角Generate就可以了。
构造方法,使用Eclipse自动生成。
右键选择Source(或者使用快捷键:Alt+Shift+s)后选择Generate Constructors using fields,根据需要勾选内容(这道题width,length都要选)之后点击右下角Generate就可以了
import java.util.Arrays;
import java.util.Scanner;
class Rectangle {
private int width;
private int length;
public Rectangle(int length, int width) {
this.length = length;
this.width = width;
}
public int getPerimeter() {
return (length + width) * 2;
}
public int getArea() {
return length * width;
}
@Override
public String toString() {
return "Rectangle [width=" + width + ", length=" + length + "]";
}
}
class Circle{
private int radius;
public Circle(int radius){
this.radius = radius;
}
public int getPerimeter() {
return (int)(Math.PI * 2 * radius);
}
public int getArea() {
return (int)(Math.PI * radius * radius);
}
public String toString() {
return "Circle[" + "radius=" + radius + ']';
}
}
public class Main {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
Rectangle[] rectangle = new Rectangle[2];
rectangle[0] = new Rectangle(input.nextInt(), input.nextInt());
rectangle[1] = new Rectangle(input.nextInt(), input.nextInt());
Circle[] circle = new Circle[2];
circle[0] = new Circle(input.nextInt());
circle[1] = new Circle(input.nextInt());
System.out.println(rectangle[0].getPerimeter() + rectangle[1].getPerimeter() + circle[0].getPerimeter() + circle[1].getPerimeter());
System.out.println(rectangle[0].getArea() + rectangle[1].getArea() + circle[0].getArea() + circle[1].getArea());
System.out.println(Arrays.deepToString(rectangle));
System.out.println(Arrays.deepToString(circle));
}
}