Tram(最短路问题)(核心用floyd写的)

题目:

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

题意:

输入理解:

第一行的N是代表下面有N个交叉点,最后输出A到B手动更换开关最少的次数

以下N行:第i行的第一个数表示第i个交叉口有ki个轨道,下面ki个数表示i能到达的轨道,ki后面的第一个数表示交叉口原来指向的轨道t(既从i到t不用换道)

输出理解:

输出从A到B改变轨道最少的次数,如果不能从A到B则输出-1

代码:

#include<iostream>
const int INF=0x3f3f3f3f;
using namespace std;


int main()
{
	int a[110][110];
	int N,A,B;
	cin>>N>>A>>B;
	
	//初始化  
	for(int i=1;i<=N;i++)
	for(int j=1;j<=N;j++)
		if(i==j)a[i][j]=0;
		else	a[i][j]=INF;
	
	for(int i=1;i<=N;i++)
	{
		int k,x;
		cin>>k;
		for(int j=1;j<=k;j++)
		{
			cin>>x;
			if(j==1)a[i][x]=0;//表示交叉口原本只想的轨道  
			else	a[i][x]=1;//表示要转换才行  
		}
	}
	
	//核心 (floyd) 
	for(int k=1;k<=N;k++)
	for(int i=1;i<=N;i++)
	for(int j=1;j<=N;j++)
		a[i][j]=min(a[i][j],a[i][k]+a[k][j]);
	
	//a[A][B]==INF表示没有从A到B的路径  
	if(a[A][B]==INF)
		cout<<-1;
	else
		cout<<a[A][B];
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值