PAT甲级--1065 A+B and C (64bit) (20 分)

题目详情 - 1065 A+B and C (64bit) (20 分) (pintia.cn)

Given three integers A, B and C in (−263,263), you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题意:

输入A,B,C,判断A+B是否大于C;(A,B,C需要使用long long 存储)大于输出true,小于输出false;

思路:

溢出定义:正数之和等于负数,负数之和等于非负数;

如果A > 0, B < 0 或者 A < 0, B > 0,sum是不可能溢出的; 如果A > 0, B > 0,sum可能会正溢出,sum范围应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2],是个负数,所以 sum < 0 说明溢出了; 如果A < 0, B < 0,sum可能会负溢出,sum范围应为[ -2^63, -2],溢出得到的结果应该是[ 0, 2^63 ],是个正数,所以 sum >= 0 说明溢出了;

注意点:

  1. A,B,C的值不能有cin输入,原因未知;

  2. 因为题目中数据没有取到2的63次方的情况,因此可以使用long long存储,否则就要用带负数的大数运算了(long long存储2的62次方时会自动变成-2的63次方,无法区分左右边界)。

  3. A+B必须存放在sum中与C比较,不能在if条件中直接与C比较,否则造成两组数据错误

    有sum = A + B时,如何比较都不会错误,无sum = A + B时,会错两组数据(原因未知,后续更新);

代码:

#include <cstdio>
using namespace std;
int main()
{
    int T = 0;
    scanf("%d", &T);
    for(int i=1; i<=T; ++i){
        long long A = 0, B = 0, C = 0, sum = 0;
        scanf("%lld%lld%lld", &A, &B, &C); //不能使用cin输入,原因未知;
        //cin >> A >> B >> C;  
        sum = A + B;
        if(A > 0 && B > 0 && sum < 0){
            printf("Case #%d: true\n", i);
        }else if(A < 0 && B < 0 && sum >= 0){
            printf("Case #%d: false\n", i);
        }else if(sum > C){
            printf("Case #%d: true\n", i);
        }else{
            printf("Case #%d: false\n", i);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值