RIP下MGRE综合实验

要求:

1.R5为ISP,只能进行IP地址配置,其所有地址均配为公有IP地址
2.R1和R5间使用PPP的PAP认证,R5为主认证方;
  R2于R5之间使用PPP的chap认证,R5为主认证方
  R3于R5之间使用HDLC封装。
3.R1/R2/R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE。
4.整个私有网络基于RIP全网可达
5.所有pc设置私有IP为源IP,可以访问R5环回。

 拓朴图:

 1.配置接口IP地址

r1

[r1]interface GigabitEthernet 0/0/0
[r1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[r1]interface Serial 4/0/0
[r1-Serial4/0/0]ip address 15.0.0.1 24

r2

[r2]interface GigabitEthernet 0/0/0
[r2-GigabitEthernet0/0/0]ip address 192.168.2.1 24
[r2]interface Serial 4/0/0
[r2-Serial4/0/0]ip address 25.0.0.1 24

 r3

[r3]interface GigabitEthernet 0/0/0
[r3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[r3]interface Serial 4/0/0
[r3-Serial4/0/0]ip address 35.0.0.1 24

 r4

[r4]interface GigabitEthernet 0/0/1
[r4-GigabitEthernet0/0/0]ip address 192.168.4.1 24
[r4]interface GigabitEthernet 0/0/0
[r4-GigabitEthernet0/0/0]ip address 45.0.0.1 24

 r5

[r5]interface GigabitEthernet 0/0/0
[r5-GigabitEthernet0/0/0]ip address 45.0.0.2 24
[r5]interface Serial 4/0/0
[r5-Serial4/0/0]ip address 35.0.0.2 24
[r5]interface Serial 3/0/0
[r5-Serial4/0/0]ip address 15.0.0.2 24
[r5]interface Serial 3/0/1
[r5-Serial4/0/0]ip address 25.0.0.2 24
[r5]interface LoopBack 0
[r5-LoopBack0]ip address 5.5.5.5 24

2.r1 r2 r3 r4 写缺省

[r1]ip route-static 0.0.0.0 0 15.0.0.2

[r2]ip route-static 0.0.0.0 0 25.0.0.2

[r3]ip route-static 0.0.0.0 0 35.0.0.2

[r4]ip route-static 0.0.0.0 0 45.0.0.2

3.配置NAT进行地址转换

r1

[r1]acl 2000
[r1-acl-basic-2000]rul 1 permit source any
[r1-acl-basic-2000]quit
[r1]interface Serial 4/0/0
[r1-Serial4/0/0]nat outbound 2000

r2

[r2]acl 2000
[r2-acl-basic-2000]rul 1 permit source any
[r2-acl-basic-2000]quit
[r2]interface Serial 4/0/0
[r2-Serial4/0/0]nat outbound 2000

r3

[r3]acl 2000
[r3-acl-basic-2000]rul 1 permit source any
[r3-acl-basic-2000]quit
[r3]interface Serial 4/0/0
[r3-Serial4/0/0]nat outbound 2000

r4

[r4]acl 2000
[r4-acl-basic-2000]rule 1 permit source any
[r4-acl-basic-2000]quit
[r4]interface GigabitEthernet 0/0/0
[r4-GigabitEthernet0/0/0]nat outbound 2000

4.R1和R5间使用PPP的PAP认证,R5为主认证方

主认证方r5

[r5]aaa
[r5-aaa]local-user huawei password cipher huawei
[r5-aaa]local-user huawei service-type ppp
[r5-aaa]quit
[r5]interface Serial 3/0/0
[r5-Serial3/0/0]ppp authentication-mode pap

被认正方r1

[r1]interface Serial 4/0/0
[r1-Serial4/0/0]ppp pap local-user huawei password cipher huawei

5.R2于R5之间使用PPP的chap认证,R5为主认证方

主认证方r5

[r5]aaa
[r5-aaa]local-user huawei password cipher huawei
[r5-aaa]local-user huawei service-type ppp
[r5-aaa]quit
[r5]interface Serial 3/0/1
[r5-Serial3/0/1]ppp authentication-mode chap

被认正方r2

[r2]interface Serial 4/0/0
[r2-Serial4/0/0]ppp chap user huawei
[r2-Serial4/0/0]ppp chap password cipher huawei

6.  R3于R5之间使用HDLC封装

r3

[r3]interface Serial 4/0/0
[r3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y

r5

[r5]interface Serial 4/0/0
[r5-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y

7.R1/R2/R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE

(1)MGRE环境的搭建

r1

[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]ip address 10.1.1.1 24
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp
[r1-Tunnel0/0/0]source 15.0.0.1
Jul 20 2023 16:34:38-08:00 r1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[r1-Tunnel0/0/0]nhrp network-id 100

r2

r2]interface Tunnel 0/0/0
[r2-Tunnel0/0/0]ip address 10.1.1.2 24
[r2-Tunnel0/0/0]tunnel-protocol gre p2mp
[r2-Tunnel0/0/0]source Serial 4/0/0
Jul 20 2023 16:37:06-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[r2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.0.0.1 register

r3

[r3]interface Tunnel 0/0/0
[r3-Tunnel0/0/0]ip address 10.1.1.3 24
[r3-Tunnel0/0/0]tunnel-protocol gre p2mp
[r3-Tunnel0/0/0]source Serial 4/0/0
Jul 20 2023 16:39:22-08:00 r3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/0 has entered the UP state.
[r3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.0.0.1 register

 (2)GRE环境的搭建

r1

[r1]interface Tunnel 0/0/1
[r1-Tunnel0/0/1]ip address 20.1.1.1 24
[r1-Tunnel0/0/1]tunnel-protocol gre
[r1-Tunnel0/0/1]source 15.0.0.1
[r1-Tunnel0/0/1]destination 45.0.0.1
Jul 20 2023 16:46:05-08:00 r1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/1 has entered the UP state.

 r4

[r4]interface Tunnel 0/0/1
[r4-Tunnel0/0/1]ip address 20.1.1.2 24
[r4-Tunnel0/0/1]tunnel-protocol gre  
[r4-Tunnel0/0/1]source 45.0.0.1
[r4-Tunnel0/0/1]destination 15.0.0.1
Jul 20 2023 16:48:07-08:00 r4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP on the interface Tunnel0/0/1 has entered the UP state.

 8.整个私有网络基于RIP全网可达

r1

[r1]rip 1
[r1-rip-1]version 2
[r1-rip-1]network 192.168.1.0
[r1-rip-1]network 10.0.0.0       MGRE的隧道
[r1-rip-1]network 20.0.0.0       GRE的隧道

[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]nhrp entry multicast dynamic           //开启伪⼴播 
[r1-Tunnel0/0/0]undo rip split-horizon                      //关闭⽔平分割

r2

[r2]rip 1
[r2-rip-1]version 2
[r2-rip-1]network 192.168.2.0
[r2-rip-1]network 10.0.0.0

 r3

[r3]rip 1
[r3-rip-1]version 2
[r3-rip-1]network 192.168.3.0
[r3-rip-1]network 10.0.0.0

r4

[r4]rip 1
[r4-rip-1]version 2
[r4-rip-1]network 192.168.4.0
[r4-rip-1]network 20.0.0.0

 9.所有pc设置私有IP为源IP,可以访问R5环回

PC1

 PC2

PC3

 

 PC4

10.测试全网可达

r1 ping r2

 r1 ping r3

 r1 ping r4

 r1 ping r5环回

 全网可达!!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值