四平方和定理,又称为拉格朗日定理:
每个正整数都可以表示为至多 4 个正整数的平方和。
如果把 0 包括进去,就正好可以表示为 4 个数的平方和。
比如:
5=02+02+12+22
7=12+12+12+22
对于一个给定的正整数,可能存在多种平方和的表示法。
要求你对 4 个数排序:
0≤a≤b≤c≤d
并对所有的可能表示法按 a,b,c,d 为联合主键升序排列,最后输出第一个表示法。
输入格式
输入一个正整数 N。
输出格式
输出4个非负整数,按从小到大排序,中间用空格分开。
数据范围
0<N<5∗106
输入样例:
5
输出样例:
0 0 1 2
哈希优化
#include <iostream>
#include <algorithm>
#define x first
#define y second
using namespace std;
typedef pair<int,int> PII;
const int N=5e6+10;
int S[N];//存储c*c+d*d
PII loc[N];//存储序号
int main(){
int n;
cin>>n;
for(int c=0;c*c<=n;c++){
for(int d=c;c*c+d*d<=n;d++){//按字典序枚举c,d
if(S[c*c+d*d]) continue;//已经记录过的c*c+d*d,后面就不需要再记录,先出现的字典序最小
S[c*c+d*d]++;
loc[c*c+d*d]={c,d};
}
}
for(int a=0;a*a<=n;a++){//按字典序枚举a,b
for(int b=a;a*a+b*b<=n;b++){
if(S[n-a*a-b*b]){
cout<<a<<' '<<b<<' '<<loc[n-a*a-b*b].x<<' '<<loc[n-a*a-b*b].y<<endl;
return 0;
}
}
}
return 0;
}
二分优化:
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct Add{
int sum;
int L;
int R;
bool operator <(const Add &t)const{//重载运算符
if(sum!=t.sum) return sum<t.sum;
if(L!=t.L) return L<t.L;
return R<t.R;
}
}Sum;
Sum temp;
const int N=5e6+10;
vector<Sum> Store;
int main(){
int n;
cin>>n;
for(int c=0;c*c<=n;c++){
for(int d=c;c*c+d*d<=n;d++){//按字典序枚举
temp.sum=c*c+d*d;
temp.L=c;
temp.R=d;
Store.push_back(temp);
}
}
sort(Store.begin(),Store.end());//会按字典序排序
for(int a=0;a*a<=n;a++){
for(int b=a;a*a+b*b<=n;b++){
int x=n-a*a-b*b;
int l=0,r=Store.size()-1;
while(l<r){
int mid=l+r>>1;
if(Store[mid].sum>=x) r=mid;
else l=mid+1;
}
if(Store[l].sum==x){
cout<<a<<' '<<b<<' '<<Store[l].L<<' '<<Store[l].R<<endl;
return 0;
}
}
}
return 0;
}
总结:蓝桥杯经常用的方法,空间换时间