蓝桥杯真题——四平方和——二分优化与哈希优化

文章介绍了如何利用拉格朗日定理解决将正整数表示为最多四个正整数平方和的问题。提供了两种优化方法,一种是哈希优化,通过存储c*c+d*d的值并按字典序枚举,另一种是二分优化,利用排序和二分查找来提高效率。这两种方法都是为了在大范围的数据中找到满足条件的最小表示法。
摘要由CSDN通过智能技术生成
四平方和定理,又称为拉格朗日定理:

每个正整数都可以表示为至多 4 个正整数的平方和。

如果把 0 包括进去,就正好可以表示为 4 个数的平方和。

比如:

5=02+02+12+22
7=12+12+12+22
对于一个给定的正整数,可能存在多种平方和的表示法。

要求你对 4 个数排序:

0≤a≤b≤c≤d
并对所有的可能表示法按 a,b,c,d 为联合主键升序排列,最后输出第一个表示法。

输入格式
输入一个正整数 N。

输出格式
输出4个非负整数,按从小到大排序,中间用空格分开。

数据范围
0<N<5∗106
输入样例:
5
输出样例:
0 0 1 2
哈希优化
#include <iostream>
#include <algorithm>
#define x first
#define y second
using namespace std;
typedef pair<int,int> PII;
const int N=5e6+10;
int S[N];//存储c*c+d*d
PII loc[N];//存储序号
int main(){
    int n;
    cin>>n;
    for(int c=0;c*c<=n;c++){
        for(int d=c;c*c+d*d<=n;d++){//按字典序枚举c,d
            if(S[c*c+d*d]) continue;//已经记录过的c*c+d*d,后面就不需要再记录,先出现的字典序最小
            S[c*c+d*d]++;
            loc[c*c+d*d]={c,d};
        }
    }
    for(int a=0;a*a<=n;a++){//按字典序枚举a,b
        for(int b=a;a*a+b*b<=n;b++){
            if(S[n-a*a-b*b]){
                cout<<a<<' '<<b<<' '<<loc[n-a*a-b*b].x<<' '<<loc[n-a*a-b*b].y<<endl;
                return 0;
            }
        }
    }
    return 0;
}
二分优化:
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct Add{
    int sum;
    int L;
    int R;
    bool operator <(const Add &t)const{//重载运算符
        if(sum!=t.sum) return sum<t.sum;
        if(L!=t.L) return L<t.L; 
        return R<t.R;
    }
}Sum;
Sum temp;
const int N=5e6+10;
vector<Sum> Store;
int main(){
    int n;
    cin>>n;
    for(int c=0;c*c<=n;c++){
        for(int d=c;c*c+d*d<=n;d++){//按字典序枚举
            temp.sum=c*c+d*d;
            temp.L=c;
            temp.R=d;
            Store.push_back(temp);
        }
    }
    sort(Store.begin(),Store.end());//会按字典序排序
    for(int a=0;a*a<=n;a++){
        for(int b=a;a*a+b*b<=n;b++){
            int x=n-a*a-b*b;
            int l=0,r=Store.size()-1;
            while(l<r){
                int mid=l+r>>1;
                if(Store[mid].sum>=x) r=mid;
                else l=mid+1;
            }
            if(Store[l].sum==x){
                cout<<a<<' '<<b<<' '<<Store[l].L<<' '<<Store[l].R<<endl;
                return 0;
            }
        }
    }
    return 0;
}

总结:蓝桥杯经常用的方法,空间换时间

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

切勿踌躇不前

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值