PTA-树的遍历(后中推先,层序遍历)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数NN\le 3030),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2
#include<stdio.h>
#include<queue>
using namespace std;
//由后序中序推先序
int post[35],in[35];
struct node{
	int data;
	node* ltree;
	node* rtree;
}; 
queue<node*>q;
node* buildtree(int postl,int postr,int inl,int inr)
{
	    if(inl>inr)
     	return NULL;
    	node* root=new node;
    	root->data=post[postr];
    	int i;
    	for(i=inl;i<=inr;i++)
    	{
    		if(in[i]==post[postr])
    		break;
		}
		int num=i-inl;
		root->ltree=buildtree(postl,postl+num-1,inl,i-1);
		root->rtree=buildtree(postl+num,postr-1,i+1,inr);
		return root;
} 
int t=1;
void printfpost()
{
	while(!q.empty())
	{
		if(q.front()->ltree!=NULL)
		q.push(q.front()->ltree);
		if(q.front()->rtree!=NULL)
		q.push(q.front()->rtree);
		if(t==1)
		printf("%d",q.front()->data);
		else
		printf(" %d",q.front()->data);
		t++;
		q.pop();
	}
}
int main()
{
	int n,i;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
    scanf("%d",&post[i]);
    for(i=1;i<=n;i++)
    scanf("%d",&in[i]);
    node* root=buildtree(1,n,1,n);
    q.push(root);
    printfpost();
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值