Children’s Queue

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8419    Accepted Submission(s): 2665


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 
#include<iostream>
using namespace std;
int f[1005][1201];
int main()
{
	
	int i,j;
	memset(f,0,sizeof(f));
	f[1][1200]=1;
	f[2][1200]=2;
	f[3][1200]=4;
	f[4][1200]=7;
	//printf("111\n");
	for(i=5;i<=1000;i++)
	{
		for(j=1200;j>=0;j--)
		{
			f[i][j]=f[i-1][j]+f[i-2][j]+f[i-4][j];
		}
		for(j=1200;j>=0;j--)
		{
			if(f[i][j]/10>0)
			{
			    f[i][j-1]+=f[i][j]/10;
				f[i][j]%=10;
			}
		}
	}
	int n;
	while(scanf("%d",&n)>0)
	{
		for(j=0;j<=1200;j++)
			if(f[n][j]!=0)
				break;
			for(;j<=1200;j++)
		printf("%d",f[n][j]);
			printf("\n");
	}
	return 0;
}
 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值