HDOJ 题目1297Children’s Queue(递推,大数)



Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10644    Accepted Submission(s): 3431


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 

Author
SmallBeer (CML)
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1480  1438  2501  1143  1267 
 

递推公式;a[i]=a[i-1]+a[i-2]+a[i-4];

ac代码

#include<stdio.h>
#include<string.h>
char a[1010][1010];
char *add(char a[],char b[],char tc[])
{
	int c[10000];
	int i,j,len1,len2,k=0,max;
	memset(c,0,sizeof(c));
	len1=strlen(a);
	len2=strlen(b);
	i=len1-1;
	j=len2-1;
	memset(c,0,sizeof(c));
	while(i>=0||j>=0)
	{
		if(i>=0&&j<0)
			c[k]+=a[i]-'0';
		else
			if(i<0&&j>=0)
				c[k]+=b[j]-'0';
			else
				c[k]+=b[j]-'0'+a[i]-'0';
			k++;
			c[k]=c[k-1]/10;
			c[k-1]%=10;
			i--;
			j--;
			if(c[k])
				max=k;
			else
				max=k-1;
	}
	j=0;
	for(i=max;i>=0;i--)
	{
		tc[j++]=c[i]+'0';
	}
	tc[j]='\0';
	return tc;
}
void fun()
{
	int i;
	//memset(a,0,sizeof(a));
	strcpy(a[0],"1");
	strcpy(a[1],"1");
	strcpy(a[2],"2");
	strcpy(a[3],"4");
	for(i=4;i<1010;i++)
	{
		add(a[i-1],a[i-2],a[i]);
		add(a[i-4],a[i],a[i]);
	}
}
int main()
{
	int n;
	fun();
	while(scanf("%d",&n)!=EOF)
	{
		printf("%s\n",a[n]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值