POJ 1797 Heavy Transportation

题目

Heavy Transportation
Time Limit : 6000/3000ms (Java/Other) Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 16 Accepted Submission(s) : 5
Problem Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

一、分析

这是一道属于迪杰斯特拉算法变形题,这里不再是求最短路径,而是要求最大承重,所以松弛部分需要做改动,其他格式差不多。
我们只需要每次选取离源点载货量“最多”的那条边,然后通过它去松弛所有路径上的最大载重量;
为什么要每次选取离源点权值最大的那个点去松弛:
我们知道原始的dijkstra是每次选取离源点最近的边去松弛使得求出的源点到其余点的单源最短路径最短,
那么我们这里希望让它路径上权值最小的边尽可能的大,我们就需要去选取离源点权值最大的点,使得它的该路径的最大载重量大一些;
【1】int f=-999999;//定义成负数即可
【2】if(!vis[j] && dis[j]>f)
【3】if(!vis[j] && dis[j]<min(dis[v],map[v][j]))
{
dis[j]=min(dis[v],map[v][j]);
}

二、代码

代码如下(示例):

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 0x3f3f3f3;
int map[1010][1010],dis[1010],vis[1010];
int n,m;
#define min(a,b) (a<b?a:b)
int dijkstra()
{
	int i,j,v;
	for(i=0;i<=n;i++)
    {
		vis[i]=0;
		dis[i]=map[1][i];//这个时候d不代表从1到n的最短路径,而是最大承载量
	}
	for(i=1;i<=n;i++)
    {
		int f=-999999;
		for(j=1;j<=n;j++)
			if(!vis[j] && dis[j]>f)//这里需要每次选取离源点权值最大的边去松弛;使得最大载重量尽可能的大;
            {
				f=dis[j];
				v=j;
			}
		vis[v]=1;

		for(j=1;j<=n;j++)
			if(!vis[j] && dis[j]<min(dis[v],map[v][j]))//又是比较绕的地方,这里是要选取每条路径中最小的权值作为该路径的最大载重量,我们又要找路径中最大载重量最大是多少,所以此时dis数组中保存的为源点到该点的最大载重量
            {
				dis[j]=min(dis[v],map[v][j]);
			}
	}

	return dis[n];

}

int main()
{
	int k=1,i,j,s,a,b,c;
	scanf("%d",&s);
    while(s--)
    {
		scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));//将map都设为0
		for(i=1;i<=m;i++)
        {
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=map[b][a]=c;
		}
		printf("Scenario #%d:\n",k);
		k++;
		printf("%d\n\n",dijkstra());
	}
	return 0;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值