Heavy Transportation(Dijkstra变形)

Heavy Transportation

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
题意:有n个城市,m条道路,在每条道路上有一个承载量,现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量(每条通路的承载量是该通路上所有道路的承载量的最小值,例:1->2承载量为3,2->3承载量为1,则1->3的承载量为1)
Dijkstra是求最短路的算法,这里变形一下(因为要求最大承载量,要使每条边的权值尽量大)

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=1005;
const int Inf=999999999;
int n,m;
int G[maxn][maxn],dis[maxn];
bool vis[maxn];
void dj(){
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	dis[i]=G[1][i];
	vis[1]=true;
	for(int k=1;k<n;k++){
		int maxt=-1,u;
	    for(int i=1;i<=n;i++){
	    	if(!vis[i]&&dis[i]>maxt){//这里是大于号
	    		maxt=dis[i];
	    		u=i;
			}
		}
		vis[u]=true;
	    for(int i=1;i<=n;i++){
	    	if(dis[i]<min(maxt,G[u][i]))//注意松弛条件
	    	dis[i]=min(maxt,G[u][i]);
		}
	}
	printf("%d\n\n",dis[n]);	
}
int main(){
	int T,u,v,w;
	scanf("%d",&T);
	for(int k=1;k<=T;k++){
		scanf("%d%d",&n,&m);
		memset(G,0,sizeof(G));
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&u,&v,&w);
			G[u][v]=G[v][u]=w;//双向联通
		}
		printf("Scenario #%d:\n",k);
		dj();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值