POJ2034Anti-prime Sequences--dfs

26 篇文章 0 订阅
26 篇文章 0 订阅
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 4127 Accepted: 1857

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

Source

East Central North America 2004

 

题目大意:给定区间【n,m】要求其中自然数排列为连续d个不为素数,

思路: dfs要求连续d个数不为素数,就把前k-1个加起来,不够k-1个就先加上

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
const int maxn = 10010;
bool su[maxn];
int vis[10100],ans[10100];
int n,m,d;
int ok;

void init()
{
    memset(su,1,sizeof(su));
    su[0]=su[1]=0;
    for(int i=2;i<=10000; i++)
    {
        if(su[i]==true)
        {
            for(int j=i*i; j<=10000; j+=i)
                su[j]=false;
        }
    }
}

void dfs(int dep)
{
    if(ok==1)
        return ;
    if(dep== m-n+2)
    {
        ok = 1;
		for(int i = 1; i < dep-1; i++)
			printf("%d,",ans[i]);
		printf("%d\n",ans[dep-1]);
		return;
    }

    for(int i=n;i<=m;i++)
    {
        if(!vis[i])
        {
            bool flag=0;

            for(int k=2;k<=d&&dep-k>=0;k++)
            {
                int sum=0;

                for(int j=dep-k+1;j<=dep-1;j++)
                    sum+=ans[j];
                if(su[sum+i]==true)
                    flag=1;
            }
            if(flag==1)
                continue;


            ans[dep]=i;
            vis[i]=1;

            dfs(dep+1);

            vis[i]=0;   
        }
    }
}

int main()
{
    init();
    while(cin>>n>>m>>d&&n&&m&&d)
    {
        
        if(n == 0 && m == 0 && d == 0) break;
        memset(vis,0,sizeof(vis));
        ok=0;
        dfs(1);
        if(ok == 0)
            printf("No anti-prime sequence exists.\n");

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值