POJ2034

Anti-prime Sequences
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 3099 Accepted: 1415

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54
源代码:

#include<iostream>

#include<cmath>
#include<cstring>
using namespace std;
const int MAX=10000;
int set[MAX+1];
bool flag[MAX+1],iflag[MAX+1];
int n,m,d;
void prime()
{
    memset(flag,0,sizeof(flag));
int t=sqrt((double)MAX)+1;                                                 
int i,j,k;
flag[0]=flag[1]=1;
for (i=2;i<=t;i++)
{
   if (flag[i]) continue;
for (j=2,k=MAX/i+1;j<k;j++)
flag[i*j]=1;
}
}
bool judge (int index,int value)  
{  
int i;
    if (index==0)  
        return true;  
    int left=index-d+1;  
    if (left<0) left=0;  
    int sum=value;    
    for (i=index-1;i>=left;i--)  
    {  
        sum+=set[i];  
        if (!flag[sum]) return false;  
    }  
    return true;  
}  
  
bool dfs ( int index )  
{  
int i;
    if (index==n-m+1)  
        return true;  
    for (i=m;i<=n;i++)  
    {  
        if (!iflag[i]&&judge(index,i))  
        {  
            set[index]=i;  
            iflag[i]=true;  
            if (dfs(index+1)) return true;  
            iflag[i]=false;  
        }  
    }  
    return false;  
}  
  
int main()  
{  
int i;
    prime();  
    while (1)  
    {  
        cin>>m>>n>>d;
        if (m+n+d==0) break;  
        memset(iflag,0,sizeof(iflag));  
        if (dfs(0))  
        {  
            for (i=0;i<n-m;i++)  
                printf("%d,",set[i]);  
            printf("%d\n",set[n-m]);  
        }  
        else printf("No anti-prime sequence exists.\n");  
    }  
    return  0;  

本题题意:给定一个区间,然后根据他给出的数,判断连续几个数之和为合数,如果给出是3,那么连续2,连续3个都得满足,然后根据这个顺序排序,最后输出这个顺序,如果没有则输出没有。深搜然后枚举1,2。。。这些顺序

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值