【POJ】1905Expanding Rods(几何方程二分求解)

Expanding Rods

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19926 Accepted: 5332

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

Source

Waterloo local 2004.06.12

题目大意:长为L的一个竿子,热n度之后长度变为L'=(1+n*C)*L,其中C是木棒的热膨胀系数。给出L,n,C,求竿子可以向上弯曲的最大值。 下面会给出一个图。。

思路:如图所示

其中我们要求出来就是上面的x

通过下面的等式,即可推出结果,

L'=(1+n*C)*L

θr = 1/2*L'

sinθ= 1/2*L/r

r*r = (1/2*L)*(1/2*L) + (r-x)*(r-x)

最后得到的是一个单调函数

#include <stdio.h>
#include <string.h>
#include <math.h>
#define eps 1e-5


int main() 
{
    double L, n, C;
    while (~scanf("%lf%lf%lf",&L,&n,&C)&&L!=-1&&n!=-1&&C!=-1)
    {

        double L1 = (1 + n*C)*L;
        double l = 0, r = L / 2, h;
        while (r-l>eps)
        {
            h = (l + r) / 2;
            double R = ((L*L / 4 + h*h) / (2 * h));
            double a = asin(L / (2 * R));
            if (R*a >= L1 / 2) r = h;
            else l = h;

        }
        printf("%.3f\n", h);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值