【HDU】3592World Exhibition(差分约束)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2346    Accepted Submission(s): 1126


 

Problem Description

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

 

 

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

 

 

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

 

 

Sample Input

 

1 4 2 1 1 3 8 2 4 15 2 3 4

 

 

Sample Output

 

19

 

 

Author

alpc20

 

 

Source

2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT

 

 

Recommend

 

题目大意:现在有N个人在看一个场地上,其中前X行表示有两个人之间的距离最少是多少,下面的Y行代表了有两个人之间的距离最大是多少,问第一个人到第 n个人之间的距离最大是多少,

思路:看到这些不等式基本上就是差分约束的题目,那么我们来做分析,

首先,X行喜欢在一起的人,

也就是:0<A-B<d,把这个式子变形成为: A-B<=d    &&    B-A<=0,正常建边就可以了

下面Y行不喜欢在一起的人,

也就是:A-B>d,变形成为B-A<-d,

正常建边后跑一边spfa就可以了,这里可能是负环的,有的话直接判断就可以了,

这里我用的是上面的那个   B-A<=0这个式子,其实还有一种就是每个人与他前面的人的距离不能为负值,这个也是可以的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 1e6 + 5;
const int INF = 0x3f3f3f3f;
struct Edge
{
    int from,to,dist;
    Edge(int f,int t,int d):from(f),to(t),dist(d) {}
};

struct BellmanFord
{
    int n,m;
    vector<Edge> edges;
    vector<int> G[maxn];
    bool inq[maxn];
    int cnt[maxn];
    int d[maxn];
    int p[maxn];

    void init(int n)
    {
        this->n=n;
        for(int i=0; i<=n; i++)
            G[i].clear();
        edges.clear();
    }

    void AddEdge(int from,int to,int dist)
    {
        edges.push_back(Edge(from,to,dist));
        m=edges.size();
        G[from].push_back(m-1);
    }

    bool negative_cycle(int s)
    {
        for (int i = 0; i <= n; i++)
            d[i] = INF;
        memset(inq, 0, sizeof(inq));
        memset(cnt, 0, sizeof(cnt));
        d[s] = 0;
        inq[s] = true;

        queue<int> Q;
        Q.push(s);

        while(!Q.empty())
        {
            int u =Q.front();
            Q.pop();
            inq[u]=false;
            for(int i=0; i<G[u].size(); i++)
            {
                Edge &e=edges[G[u][i]];
                if(d[e.to]> d[u]+e.dist&&d[u]<INF)
                {
                    d[e.to] = d[u]+e.dist;
                    p[e.to] = G[u][i];
                    if(!inq[e.to])
                    {
                        inq[e.to]=true;
                        Q.push(e.to);
                        if(++cnt[e.to]>n)
                            return true;
                    }
                }
            }
        }
        return false;
    }
} BF;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,x,y;
        scanf("%d%d%d",&n,&x,&y);
        BF.init(n);
        while(x--)
        {
            int a,b,d;
            scanf("%d%d%d",&a,&b,&d);
            BF.AddEdge(a,b,d);
                BF.AddEdge(b,a,0);
        }
        while(y--)
        {
            int a,b,d;
            scanf("%d%d%d",&a,&b,&d);
            BF.AddEdge(b,a,-d);
        }
        /*for (int i = 2; i <= n; i++)
            BF.AddEdge(i, i- 1, -1);*/
        if (!BF.negative_cycle(1))
        {
            if (BF.d[n] == INF)
                printf("-2\n");
            else
                printf("%d\n", BF.d[n]);
        }
        else
            printf("-1\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值