HDU 5437 Alisha’s Party

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2736    Accepted Submission(s): 741


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value   v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let   p  people enter her castle. If there are less than   p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query   n  Please tell Alisha who the   nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,   T  , where   1T15 .

In each test case, the first line contains three numbers   k,m  and   q  separated by blanks.   k  is the number of her friends invited where   1k150,000 . The door would open m times before all Alisha’s friends arrive where   0mk . Alisha will have   q  queries where   1q100 .

The   ith  of the following   k  lines gives a string   Bi , which consists of no more than   200  English characters, and an integer   vi ,   1vi108 , separated by a blank.   Bi  is the name of the   ith  person coming to Alisha’s party and Bi brings a gift of value   vi .

Each of the following   m  lines contains two integers   t(1tk)  and   p(0pk)  separated by a blank. The door will open right after the   tth  person arrives, and Alisha will let   p  friends enter her castle.

The last line of each test case will contain   q  numbers   n1,...,nq  separated by a space, which means Alisha wants to know who are the   n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing   n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose
 

Source
 



///题意:优先队列模拟 阿丽莎过生日 邀请了k个朋友去做客 ,但是她卧室太小了 所以先让他们到客厅 每个朋友都带着价值v的礼物来的 ,阿丽莎会开卧室门m次 当第t个人来了后 她会带p个人进卧室把礼物放下
///规则@: 礼物价值大的先进 相同价值的 先来的先进
///最后一次开门后如果还有没放下礼物的按照同样规定进卧室放礼物,q次询问,询问第i个进入卧室的人是谁
///坑点1:开卧室门m次,需要对m个人进行按编号排序
///坑点2:开卧室门m次后,如果仍有人没进入卧室,则应按之前的规则@进入
///误区:如果每次开门,所允许进入的人数大于当前人数,则当前空出来的允许进入权并不算在下一次开门所允许进入人数中



#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int num;
    int value;
    char name[210];
}peo[150010];
struct nodo
{
    int t;
    int p;
}per[150010];
int numname[150010];
int ans;
bool operator < (const node &t1,const node &t2)
{
    if(t1.value==t2.value)  
    {
        return t1.num>t2.num; /// 按编号从小到大排序,编号小的先出队列
    }
    else return t1.value<t2.value; /// 按价值从大到小排序,m价值大的先出队列
}

bool cmp(nodo x,nodo y)
{
    return x.t<y.t;  
}

int main()
{
    int T;
    int k,m,q,n;
    int i,j;
    scanf("%d",&T);
    while(T--)
    {
        priority_queue<node>qu;  ///优先队列
        ans=0;
        scanf("%d%d%d",&k,&m,&q);
        for(i=1;i<=k;i++)
        {
            scanf("%s%d",peo[i].name,&peo[i].value);
            peo[i].num=i;
        }
        memset(per,0,sizeof(per));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&per[i].t,&per[i].p);
        }
        sort(per,per+m+1,cmp);
        for(i=1;i<m;i++)
        {
            if(per[i].t==per[i+1].t)
            {
                per[i].t+=per[i+1].t;
                for(j=i+1;j<m;j++)
                {
                    per[j]=per[j+1];
                }
                m--;
                i--;
            }
        }
        memset(numname,0,sizeof(numname));
        for(i=1;i<=m;i++)
        {
            for(j=per[i-1].t+1;j<=per[i].t;j++)
            {
                qu.push(peo[j]);
            }
            while(!qu.empty())
            {
                node x=qu.top();
                numname[++ans]=x.num;
                per[i].p--;
                qu.pop();
                if(per[i].p==0)  break;
            }
        }
        for(j=per[m].t+1;j<=k;j++)
        {
            qu.push(peo[j]);
        }
        while(!qu.empty())
        {
            node x=qu.top();
            numname[++ans]=x.num;
            qu.pop();
        }
        int flag=0;
        while(q--)
        {
            scanf("%d",&n);
            if(flag==0)
            {
                flag=1;
               printf("%s",peo[numname[n]].name);
            }
            else printf(" %s",peo[numname[n]].name);
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值