2011百校联动“菜鸟杯”程序设计公开赛_A A Simple Problem

9 篇文章 0 订阅
4 篇文章 0 订阅

A Simple Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 5749    Accepted Submission(s): 1516


Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
 

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
 

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
 

Sample Input
 
 
2 2 3
 

Sample Output
 
 
-1 1
 

Author
HIT

#include <stdio.h>
#include <math.h>
int main()
{
	int n,i,j;
	long t,x;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&t);
		j=0;
		for(i=sqrt(t);i>=1;i--){
			if(t%i==0&&(i+t/i)%2==0&&i!=(t/i))
			{
				x=fabs(t/i-i)/2;j=1;break;}
				
				}
				if(j==1&&x!=0)printf("%ld\n",x);
				else
					printf("-1\n");
				
			}
			return 0;
		
	}
	

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值