UVa10976 - Fractions Again?!

  It is easy to see that for every fraction in the form 1/k (k > 0), we can always find two positive integers
x and y, x ≥ y, such that:
                                                              1/k = 1/x + 1/y
  Now our question is: can you write a program that counts how many such pairs of x and y there
are for any given k?
Input
  Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
  For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of

x and y, as shown in the sample output.


Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21

1/12 = 1/24 + 1/24

------------------------

题意:输入正整数k,找到所有的正整数x>=y,使得1/k = 1/x + 1/y

分析:

1.既然要求找出所有的x、y,枚举对象自然就是x、y了。可问题在于,枚举的范围如何? 从1/12=1/156+1/13可以看出,x可以比y大很多。难道要无休止地枚举下去?当然不是。由 于x≥y,有 ,因此 ,即y≤2k。这样,只需要在2k范围之内枚举y,然后根据y尝试 计算出x即可。(该分析来自刘汝佳书)

2.公式转换x = (k * y) / (y - k),由该公式得出 y定大于k,所以y的枚举量缩小到 k < y <= 2k

-----------------------

#include<iostream>
#include<string.h>
using namespace std;
int main(){
	int n;
	int cnt;
	int u[10005],v[10005];
	while(cin>>n){
		memset(u,0,sizeof(u));
		memset(v,0,sizeof(v));
		cnt = 0;
		for(int y = n+1; y <= 2*n; y++){//枚举y 
			if((y*n) % (y - n) == 0){//尝试算出x,x必须是整数 
				u[cnt] = y;//记录 
				v[cnt] = (y * n) / ( y - n);
				cnt++;
			}
		}
		cout<<cnt<<endl;
		for(int i = 0; i < cnt; i++){
			cout<<"1/"<<n<<" = "<<"1/"<<v[i]<<" + "<<"1/"<<u[i]<<endl;
		}
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值