V - The Fun Number System

In a k bit 2's complement number, where the bits are indexed from 0 to k-1, the weight of the most significant bit (i.e., in position k-1), is -2^(k-1), and the weight of a bit in any position i (0 ≤ i < k-1) is 2^i. For example, a 3 bit number 101 is -2^2 + 0 + 2^0 = -3. A negatively weighted bit is called a negabit (such as the most significant bit in a 2's complement number), and a positively weighted bit is called a posibit.
A Fun number system is a positional binary number system, where each bit can be either a negabit, or a posibit. For example consider a 3-bit fun number system Fun3, where bits in positions 0, and 2 are posibits, and the bit in position 1 is a negabit. (110)Fun3 is evaluated as 2^2-2^1 + 0 = 3. Now you are going to have fun with the Fun number systems! You are given the description of a k-bit Fun number system Funk, and an integer N (possibly negative. You should determine the k bits of a representation of N in Funk, or report that it is not possible to represent the given N in the given Funk. For example, a representation of -1 in the Fun3 number system (defined above), is 011 (evaluated as 0 - 2^1 + 2^0), and
representing 6 in Fun3 is impossible.
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case is given in three consecutive lines. In the first line there is a positive integer k (1 ≤ k ≤ 64). In the second line of a test data there is a string of length k, composed only of letters n, and p, describing the Fun number system for that test data, where each n (p) indicates that the bit in that position is a negabit (posibit).
The third line of each test data contains an integer N (-2^63 ≤ N < 2^63), the number to be represented in the Funk number
system by your program.
Output
For each test data, you should print one line containing either a k-bit string representing the given number N in the Funk number system, or the word Impossible, when it is impossible to represent the given number.
Sample Input
2
3
pnp
6
4
ppnn
10
Sample Output

Impossible1110

题意:各个位数带符号的二进制。输入t表示有t个测试数据,k表示有k位,再输入k个字符,其中p表示+2^i,n表示-2^i,再输入一个十进制数long long n,满足则输出该二进制数,不满足输出Impossible,思路从高位到地位转二进制,取符合的值。如果计算到某位为偶数则该位0,p,n对下一位不影响;奇数时,该位为一,但p,n对下一位有影响,为p(虽然位为p并且为正数时不减无所谓,但为负数时需要减一)时需要减一,n时加一。如果有答案,则n此时为0

#include<iostream>
using namespace std;
char a[75];
int main()
{
 long long n;
 int i,t,k;
 cin>>t;
 while(t)
 {
  t-=1;
  cin>>k;
  cin>>a;
  cin>>n;
  while(k)
  {
   k-=1;
   if(n%2==1||n%2==-1)//负数的余数会有负数
   {
    if(a[k]=='n')
    {
     n+=1; 
    }
    else
    {
     n-=1;//当为负数时,因为p是表示正的,因此 需要减一
    }
    a[k]='1';
    n/=2;
   }
   else
   {
    a[k]='0';
    n/=2; 
   }
  }
  if(n)
  {
   cout<<"Impossible"<<endl;
  }
  else
  {
   cout<<a<<endl;
  }
 }
 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值