NYOJ 5 Binary String Matching (kmp 字符串匹配)

38 篇文章 0 订阅
10 篇文章 0 订阅

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
来源
网络
上传者
naonao

南阳oj上这道题太水了;直接用朴素算法暴力就水过了,数据量太少了,然后我们把题目移到我们自己的oj上,自己多出了一些数据,测试了一下,朴素算法用时3300ms,kmp用时1700ms左右,仅供参考,足以显示出kmp算法的优越性啊,最近两天也看了好久kmp,感觉有些细节的地方还是理解的不到位;还是要多回顾理解,看的是july大神的博客kmp算法 讲的比较详细,多读几遍,大话数据结构上分析的也比较好;供自己以后复习回顾;
下面是朴素算法过的,暴力;
朴素算法关键在于回溯,处理好回溯;
#include <cstdio>
#include <cstring>
int main()
{
    int n,count;
    char a[200],b[1200];
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        count=0;
        int i=0,j=0,len;
        scanf("%s\n%s",a,b);
        len=strlen(b);
        while(i<=len)
        {
        	if(a[j]=='\0')
            {
                count++;
                i=i-j+1; 
                j=0;
            }
            else if(a[j]==b[i])
            {
                i++;
                j++;
            }
            else
            {
                i=i-j+1; //关键在于回溯
                j=0;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}
下面是kmp算法,还要多多加强,巩固理解;
朴素算法中的回溯很多是不必要的,所以就有了kmp算法,用一个next数组储存下一次要匹配的位置,这里难理解的就是next数组,其中还要理解后缀和前缀的关系,通过匹配字符串前后的联系,得出next数组;而就不需要移动主串的位置;节约了回溯的时间;
#include<cstdio>
#include<cstring>
int nextval[200];
void get_next(char a[])//得到next数组;
{
    int len;
    int i=0,j=-1;
    nextval[0]=-1;
    len=strlen(a);
    while(i<=len)
    {
        if(j==-1 || a[i]==a[j])
        {
            ++i;
            ++j;
            if(a[i]==a[j])
            nextval[i] = nextval[j];  //把回溯的内容全换成是next数组;
            else
            nextval[i] = j;
        }
        else
            j=nextval[j];
    }
}
int kmp(char a[],char b[])//kmp的主体函数
{
    int i=0,j=0,count=0;
    int lena,lenb;
    lena=strlen(a);
    lenb=strlen(b);
    get_next(a);
    while(i<=lenb)
    {
        if(j==-1 || a[j]==b[i])
        {
            ++i;
            ++j;
        }
        else
            j=nextval[j];
        if(j>=lena)
        {
            count++;
            j=nextval[j];
        }
    }
    return count;
}
int main()
{
    int n;
    char a[20],b[1200];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s\n%s",a,b);
        printf("%d\n",kmp(a,b));
    }
    return 0;
}




  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值