HDU--1394(线段树)

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 
 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
 

Output

For each case, output the minimum inversion number on a single line. 
 

Sample Input

    
    
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output

    
    
16
 每输入一个数就计算下它之前有多少数比它大,和用线段树维护,时间复杂度就从n*n变成了n*logn,抄的别人的模板,每次新的移到后面,逆序数都会有规律,因为这些数都是不重复的。

代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxd=200000+5;
const int maxn=10000+5;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
typedef long long ll;
typedef pair<int,int> pii;
//---------------------------
int sum[maxd<<2],x[maxd];

void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1 | 1];
}

void build(int l,int r,int rt)
{
    sum[rt]=0;
    if(l==r) return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}

void update(int v,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]++;
        return;
    }
    int m=(l+r)>>1;
    if(v<=m) update(v,lson);
    else update(v,rson);
    pushup(rt);
}

int query(int L,int R,int l,int r,int rt)
{
    if(L<=l && r<=R)
        return sum[rt];
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m) ret+=query(L,R,lson);
    if(R>m) ret+=query(L,R,rson);
    return ret;
}

int main()
{
    int kase=1;
    int n,q;
    freopen("1.txt","r",stdin);
    while(scanf("%d",&n)!=EOF )
    {
        build(1,n,1);
        int ans=0;
        for(int i=1; i<=n; ++i)
        {
            scanf("%d",&x[i]);
            ans+=query(x[i]+1,n,1,n,1);
            update(x[i],1,n,1);
        }
        int tmp=ans;

        for(int i=1; i<=n; ++i)
        {
            tmp+=(n-1-x[i])-x[i];
            ans=min(ans,tmp);
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值