1065 A+B and C (64bit)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−263​​ ,263​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
分析

a,b,c,sum(=a+b)均定义为long long,范围为[-263,263-1],当a,b同号时相加可能存在溢出,当a,b均为正数时,a+b的范围是(0,264-2],溢出的范围是[263,264-2],在long long范围内表示为[2-63,-2],所以溢出时,sum<0,263==2-63,264==0,同理当a,b均为负数时,a+b的范围是[-264,0),在[-264,-2-63-1]范围内会溢出,这个范围在long long中表示为[0,263-1],所以溢出时,sum>=0,当sum没有溢出时,可以按照常规判断。
注:关于整形数的表示范围的推演可以参考博客1或者阅读计算机组成原理相关书籍

在和群友交流时出现有的使用c语言实现,发现必须在if中计算好的和值sum进行比较判断才能AC(i.e. 先计算sum=a+b,再在if中判断),而直接在if中使用if(a+b)进行判断发现测试点1,2(从0开始)无法AC,但是用c++验证两种都能AC~,说明PAT c++的编译器在处理溢出时候采取常规的方法(i.e.算出来时啥就是啥2,存在两正数溢出后变成负数的情况,但是c编译器没有采取常规方法处理,及可能在编译过程中偷偷将数据的类型发生变化,或者编译器自认为两个正数相加不会为负,自动将和值为负的情况,即将溢出情况视为条件假(false,认为不可能发生)而将此段代码删除(或者跳过)(群里大神提供的思路),造成这段代码不起作用,这样的错误比较难以排查,为规避这样的情况出现,我认为在做编程算法题的时候尽量将变量的类型由我们自己控制,具体地说,将变量类型在程序中定一下,不让compiler替我们做判断或者修改,这样可以规避一些错误~~

#include<iostream> 
using namespace std;
int main(){
	int t;
	cin>>t;
	for(int i=1;i<=t;i++){
		long long a,b,c,sum;
		cin>>a>>b>>c;
		sum=a+b;
		if(a>0 && b>0 && sum<0) printf("Case #%d: true\n",i);
		else if(a<0 && b<0 && sum>=0) printf("Case #%d: false\n",i);
		else printf("Case #%d: %s\n",i,sum>c?"true":"false");
	}
}

  1. https://www.cnblogs.com/luojialin/p/4764745.html ↩︎

  2. https://coolshell.cn/articles/11466.html ↩︎

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值