1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​ N​2​​ aN​2​​ … NK​​ a​Nk

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
分析:

用数组的索引表示指数,用数组的值表示这个指数项的系数。
C++代码

#include<iostream>
using namespace std;
const int N=1010;
double c[N];
int main() {
    int ne,nc,a;
    double b;
    cin>>ne;
    for(int i=0; i<ne; i++) {
        cin>>a>>b;
        c[a]=b;
    }
    cin>>nc;
    for(int i=0; i<nc; i++) {
        cin>>a>>b;
        c[a]+=b;
    }
    int cnt=0;
    for(int i=0; i<N; i++) {
        if(c[i]) cnt++;
    }
    cout<<cnt;
    for(int i=N; i>=0; i--) {
        if(c[i]) printf(" %d %.1lf",i,c[i]);
    }
    return 0;
}

C代码

#include<stdio.h>
#include <math.h>
#define N 1010
double c[N];
int main() {
    int ne,nc,a,i,cnt=0;
    double b;
    scanf("%d",&ne);
    for(i=0; i<ne; i++) {
        scanf("%d %lf",&a,&b);
        c[a]=b;
    }
    scanf("%d",&nc);
    for(i=0; i<nc; i++) {
        scanf("%d %lf",&a,&b);
        c[a]+=b;
    }
    for(i=0; i<N; i++) {
        if(c[i]) cnt++;
    }
    printf("%d",cnt);
    for(i=N; i>=0; i--) {
        if(fabs(c[i]-0.0)>0.000001) printf(" %d %.1lf",i,c[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值