(解题报告)HDU1001---Sum problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 372618 Accepted Submission(s): 93378

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

解题要点

  • 用while(scanf()!=EOF)输入;
  • 两种求法,第一种直接利用for累加,第二种利用公式求;
  • 第一种
  • 注意数据范围,因使用long long 类型———定义 __int64 调用 %I64d
  • 第二种
  • 使用sum=n*(n+1)/2错误,原因是n * (n+1)的数据范围可能超过32位,所以应该使用sum=n/2 * (n+1)或 sum=(n+1)/2 * n;
  • 注意每个例子后面都有一行空行

    第一种代码如下:

#include <stdio.h>
int main ()
{
    int i,n;
    __int64 sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;          //每算完一次都将sum清0 
        for(i=1;i<=n;i++)
        {
            sum+=i;
        }
        printf("%I64d\n",sum);
        printf("\n");
    }
    return 0;
}

第二种代码如下:

#include<stdio.h>
int main()
{
    int n,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n%2==0)
            sum=n/2*(n+1);
         else
            sum=(n+1)/2*n;
        printf("%d\n\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值