Language:Default
Catch That Cow
Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it? Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input 5 17 Sample Output 4 Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
|
版本一:
#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=100001;
bool vis[maxn];//标记数组
int step[maxn];//记录到了每一位置所走的步数
queue <int> q;//定义队列
int bfs(int n,int k)
{
int head,next;
q.push(n); //开始FJ在n位置,n入队
step[n]=0;
vis[n]=true; //标记已访问
while(!q.empty()) //当队列非空
{
head=q.front(); //取队首
q.pop(); //弹出对首
for(int i=0;i<3;i++) //FJ的三种走法
{
if(i==0) next=head-1;
else if(i==1) next=head+1;
else next=head*2;
if(next<0 || next>=maxn) continue; //排除出界情况
if(!vis[next]) //如果next位置未被访问
{
q.push(next); //入队
step[next]=step[head]+1; //步数+1
vis[next]=true; //标记已访问
}
if(next==k) return step[next]; //当遍历到结果,返回步数
}
}
}
int main()
{
int n,k;
while(cin>>n>>k)
{
memset(step,0,sizeof(step));
memset(vis,false,sizeof(vis));
while(!q.empty()) q.pop(); //注意调用前要先清空
if(n>=k) printf("%d\n",n-k);
else printf("%d\n",bfs(n,k));
}
return 0;
}
版本二:
//广度搜索基本思想:遍历这一层,而后遍历下一层
//取出头结点,然后把下一层所有可能入队
//剪枝很重要
//BFS+模拟队列
#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#define size 2000000
using namespace std;
int n,k;
int vis[size];
struct node{
int x,step;
};
queue<node> q;
void BFS()
{//搜索三种情况
int X,S;
while(!q.empty())
{
node tmp = q.front();
q.pop();
X = tmp.x;
S = tmp.step;
if(X == k)
{
cout<<S<<endl;
//break;
return;
}
if(X<=k && !vis[X+1])
{
node t;
vis[X+1] = 1;
t.x = X+1;
t.step = S+1;
q.push(t);
}
if(X >= 1 && !vis[X-1]) //要保证-1后有意义,故X>=1
{
node t;
vis[X-1] = 1;
t.x = X-1;
t.step = S+1;
q.push(t);
}
if(X<=k && !vis[X*2])
{
node t;
vis[X*2] = 1;
t.x = X*2;
t.step = S+1;
q.push(t);
}
}
}
int main()
{
cin>>n>>k;
memset(vis,0,size);
node tmp;
vis[n] = 1;
tmp.x = n;
tmp.step = 0;
q.push(tmp);
BFS();
return 0;
}