20140723 【字典树 - 前缀树,数组模拟指针】 HDOJ 1305 Immediate Decodability

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author ID 
Password 
  Register new ID

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1818    Accepted Submission(s): 929


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
      
      
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
      
      
Set 1 is immediately decodable Set 2 is not immediately decodable
 

Source
 

Recommend
Eddy
 

Statistic |  Submit |  Discuss |  Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.000403(s) query 1, Server time : 2014-07-23 14:01:56, Gzip enabled









#include <stdio.h>
#include <string.h>
using namespace std;
#define MAX_son 2
#define MAX_node 1001000

char s[MAX_node];

int sz;
int ch[MAX_node][MAX_son];
int en[MAX_node];

void trie(){
    memset(ch[0], 0, sizeof(ch[0]));
    sz = 1;
    memset(en, 0, sizeof(en));
}

int idx(char *s){
    return *s-'0';
}

int Insert(char *s){
    int u = 0;
    while( *s ){
        int c = idx(s);  
        if( !ch[u][c] ){
            memset(ch[sz], 0, sizeof(ch[sz]));
            en[sz] = -2;
            u = ch[u][c] = sz; 
            sz++;

        }
        else{
        u = ch[u][c];
        if( en[u]==1 )  return 0;
        en[u] = -1;   
        }
        s++;
    }
    if( en[u]==-1 )  return 0;
    en[u] = 1;
    return 1;
}

int main(){    
    for(int t=1; EOF != scanf("%s", s) ; t++){
        int ans = 1;
        trie();       
        Insert(s);
        while( 1 ){
            scanf("%s", s);
            if( s[0]=='9' ) break;
            if( ans ){
                ans = Insert(s);
            }
        }
        printf("Set %d is %simmediately decodable\n", t, ans?"":"not ");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值