20140916 【 贪心 】 bestcoder #2 + hdoj 4883 TIANKENG’s restaurant

14 篇文章 0 订阅
5 篇文章 0 订阅

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 829    Accepted Submission(s): 375


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
      
      
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
      
      
11 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5017  5016  5015  5014  5013 
 

Statistic |  Submit |  Discuss |  Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.029331(s) query 7, Server time : 2014-09-16 15:51:10, Gzip disabled





这种题目,采用贪心的方法。

起点 + n

终点 - n

然后对所有时间点扫一遍(进行累加)

过程中得到的最大值就是正解。。。

(注意:起始与终止时间点重合时,要怎么处理)


在本题中:

起止重合时,

允许先减,不允许先加。


所以:

1. 要么对时间点排序时,时间重叠的,先排减时间。

2. 要么累加时间点的值时,把同一时间点的值先累加起来。

如下两份代码。。。





#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 10100
#define MIN 0
struct PP{
    int n, t;
}a[MAXN*2];

bool cmp(const PP a, const PP b){
    if( a.t==b.t )    
        return a.n<b.n;
    return a.t<b.t;
}

int n;
int main(){    
    int T;
    while( EOF != scanf("%d\n", &T) ){
        while( T-- ){
            scanf("%d\n", &n);
            int m = n<<1;
            for(int i=0, s,e; i<n; i+=1){
                scanf("%d %2d:%2d %2d:%2d\n", &a[i].n, &a[i].t, &s, &a[i+n].t, &e);
                a[i].t = a[i].t*60 + s;
                a[i+n].n = -a[i].n;
                a[i+n].t = a[i+n].t*60 + e;
            }
            sort(a, a+m, cmp);
            long long ans=MIN, now=MIN;
            for(int i=0; i<m; i++){
                now += a[i].n;
                ans = max(ans, now);
            }
            printf("%lld\n", ans);
        }
    }
    return 0;
}




#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 10100
#define MIN 0
struct PP{
    int n, t;
}a[MAXN*2];
bool cmp(const PP a, const PP b){   return a.t<b.t; }
int n;
int main(){     
    int T;
    while( EOF != scanf("%d\n", &T) ){
        while( T-- ){
            scanf("%d\n", &n);
            for(int i=0, s,e; i<n; i++){
                scanf("%d %2d:%2d %2d:%2d\n", &a[i].n, &a[i].t, &s, &a[i+n].t, &e);
                a[i].t = a[i].t*60 + s;
                a[i+n].n = -a[i].n;
                a[i+n].t = a[i+n].t*60 + e;
            }
            int m = n<<1;
            sort(a, a+m, cmp);
            long long ans=MIN, now=MIN;
            for(int i=0, k; i<m; i=k){
                k = i+1;
                while( k<m && a[i].t==a[k].t ){
                    a[i].n += a[k].n;
                    k++;
                }
                now += a[i].n;
                ans = max(ans, now);
            }
            printf("%lld\n", ans);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值