HDU 3117 Fibonacci Numbers

The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.
Bus Schedules

What is the numerical value of the nth Fibonacci number?

输入:

For each test case, a line will contain an integer i between 0 and 108 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“…”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).

样例输入:
0
1
2
3
4
5
35
36
37
38
39
40
64
65

样例输出:
0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023…4155
1061…7723
1716…7565

解题思路:

很显然费波纳数的后四位存在周期,通过测试可以发现后四位的周期为15000,所以后四位可以打表得出,

前四位是参考了别人的思路才做出来的。

因为费波纳数f[n] = 1/sqrt(5)(((1+sqrt(5))/2)^n+((1-sqrt(5))/2)^n).

很显然当n非常大的时候(1-sqrt(5))/2)^n非常的小以至于可以忽略,假设F[n]可以表示成 t * 10^k(t是一个小数),那么对于F[n]取对数log10,答案就为log10 t + K,此时很明显log10 t<1,于是我们去除整数部分,就得到了log10 t ,再用pow(10,log10 t)我们就还原回了t。将t×1000就得到了F[n]的前四位。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;

int f[15000],F[40] = {0,1,1,2,3,5,8,13},n;
int main()
{
    f[0] = 0 ;
    f[1] = 1;
    for(int i = 2; i <= 14999; i++)
    {
        f[i] = (f[i-1] + f[i-2])%10000;
    }
    for(int i = 7; i < 40; i++)
        F[i] = F[i-1] + F[i-2];
    while(scanf("%d",&n) != EOF)
    {
        if(n < 40)
            printf("%d\n",F[n]);
        else
        {
            double a=(1.0+sqrt(5.0))/2.0;
            double ans=-0.5*(log10(5.0))+n*log10(a);
            ans-=(int)ans;
            ans=pow(10.0,ans);
            while(ans<1000)
                ans*=10;
            printf("%d...",(int)ans);
            printf("%4.4d\n",f[n%15000]);
        }
    }
    return 0;
}

参考:http://blog.csdn.net/luo964061873/article/details/7945134

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值