1075 PAT Judge

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

解题思路:比较简单,但是比较繁琐的一道题,因为要考虑的情况很多,一直最后测试点过不了,理逻辑理了好久。

tips:

1.首先是没有提交和虽然提交过但是所有提交都是未通过编译的用户不用显示
2.一道题如果只被未通过编译的提交过,那么最后显示的分数应该是0
3.一道题如果没有被提交过显示的才是-
4.一道题如果已经通过编译提交过,后面可能还会有未通过编译的提交,需要考虑,不能覆盖结果
5.多次满分提交的情况也需要考虑

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct user{
    //id
    int id;
    //获取到的总分
    int score = 0;
    //获取满分的题数
    int per_solve = 0;
    //编译通过的提交数
    int pass = 0;
    //每道题获取到的分数
    int obtained[6] ;
};
bool cmp(const user u1, const user u2){
    if (u1.score > u2.score){
        return true;
    }
    else if (u1.score == u2.score){
        if (u1.per_solve > u2.per_solve){
            return true;
        }
        else if(u1.per_solve ==  u2.per_solve){
            if (u1.id < u2.id){
                return true;
            }
            else {
                return false;
            }
        }
        else{
            return false;
        }
    }
    else{
        return false;
    }
}
int main(){
    for (int n, k, m; scanf("%d%d%d", &n, &k, &m) != EOF;){
        int* arr = new int[k+1];
        for (int i = 1; i <= k; i++){
            scanf("%d", &arr[i]);
        }
        user* users = new user[n + 1];
        for (int i = 1; i <= n; i++){
            for (int j = 1; j <= k; j++){
                users[i].obtained[j] = -1;
            }
        }
        while (m--){
            int id;
            int problem;
            int get_score;
            scanf("%d%d%d", &id, &problem, &get_score);
            users[id].id = id;
            if (get_score != -1){
                users[id].pass++;
                if (get_score > users[id].obtained[problem]){
                    //users[id].score = users[id].score - users[id].obtained[problem] + get_score;
                    users[id].obtained[problem] = get_score;
                    //可能会有多次满分的提交
                    if (get_score == arr[problem]){
                        users[id].per_solve++;
                    }
                }
            }
            else{
                //之前通过编译的提交不能被后面未通过编译的提交覆盖
                if (users[id].obtained[problem] == -1)
                    users[id].obtained[problem] = 0;
            }
        }
        vector<user>comp;
        for (int i = 1; i <= n; i++){
            if (users[i].id == i && users[i].pass){
                for (int j = 1; j <= k; j++){
                    if (users[i].obtained[j]!= -1)
                        users[i].score += users[i].obtained[j];
                }
                comp.push_back(users[i]);
            }
        }
        sort(comp.begin(), comp.end(),cmp);
        int rank = 1;
        int per_score = comp[0].score;
        for (int i = 0; i < comp.size(); i++){
            if (comp[i].score < per_score){
                per_score = comp[i].score;
                rank = i + 1;
            }
            printf("%d %05d %d", rank, comp[i].id, comp[i].score);
            for (int j = 1; j <= k; j++){
                if (comp[i].obtained[j] != -1){
                    printf(" %d", comp[i].obtained[j]);
                }
                else{
                    printf(" -");
                }
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值