1048 Find Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

解题思路:真的是PAT虐我千百遍,我待PAT如初恋,很简单的一道题,开一个面值的数组,已面值为数组下标,存放该面值的硬币的数量,然后从i=1开始遍历,看m-i的面值的硬币是否存在,如果存在,直接输出就好了,需要考虑输出两个面值一样的硬币的情况。
!!!重点来了!!!
题目中说

The second line contains N face values of the coins, which are all positive numbers no more than 500.

每个硬币的面额不超过500,那我就开了一个505的数组,我想这应该够了吧,结果测试点3死活过不了,数组开城1001才过。PAT你也真是够了,能老老实实按照题目意思来吗。

#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
    for (int n, m; scanf("%d%d", &n, &m) != EOF;){
        int coins[1001] = { 0 };
        for (int i = 0; i < n; i++){
            int temp;
            scanf("%d", &temp);
            coins[temp]++;
        }
        int flag = 0;
        for (int i = 1; i < m; i++){
            if (coins[i]>0){
                coins[i]--;
                if (coins[m - i]>0){
                    flag = 1;
                    printf("%d %d\n", i, m-i);
                    break;
                }
                coins[i]++;
            }
        }
        if (!flag){
            printf("No Solution\n");
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值