Problem - 1028 Ignatius and the Princess III

题目描述

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627

题意不难理解 首先想到的就是递归了,很显然 4=4+0=3+1+0=2+2+0=2+1+1+0=1+1+1+1,其实就是4等于1加3,然后看3的分解,一步一步往下分解。

一开始以为很简单,可以建立一个二维数组a[n][i],n表示该输入的数,i表示该分组数里1的个数,其实这样还增大了递归的复杂性,最后还是要用递归一层一层的算。

实际代码

#include<stdio.h>
#include<string.h>

int dp[125][125];
//dp[ n ][ m ]表示 n 表示成最大的数不超过 m 的方法数
int calc( int n, int m )
{

    if( dp[n][m] != -1 )
        return dp[ n ][ m ];

    if(n < 1 || m < 1) return dp[ n ][ m ] = 0;
    if(n == 1 || m == 1) return dp[ n ][ m ] = 1;
    if(n < m) return dp[ n ][ m ] = calc( n, n );
    if(n == m) return dp[ n ][ m ] = calc( n, m-1 ) + 1;

    return dp[ n ][ m ] = calc( n, m-1 ) + calc( n-m, m );

}
int main( )
{
    int n;
    memset( dp, -1, sizeof(dp) );            //将dp数组所有元素都初始化为-1

    while( scanf("%d",&n) != EOF )
      printf("%d\n",calc( n, n ) );
    return 0;
}


找了一下其他的解答,发现大部分用的母函数???

母函数的意思就是把n 用1,2,3,4,5`````来表示的种数,构造母函数:(1+x+x^2+x^3+`````)*(1+x^2+x^4+````)*(1+x^3+x^6+````)````

不是很理解额。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值