hdu1028 Ignatius and the Princess III

  母函数详情链接  Tanky Woo讲解    http://wenku.baidu.com/view/d0e5cc4433687e21af45a9a8.html?qq-pf-to=pcqq.c2c    

 Ignatius and the Princess III

                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                Total Submission(s): 12786    Accepted Submission(s): 9042
 
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 
本题的母函数为
代码:
#include<stdio.h>
#include<string.h>
int c1[10000],c2[10000];
int main()
{
    int n,i,j,k;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        for(i=0;i<=n;i++)       // -----------(1)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(i=2;i<=n;i++){       //-----------(2)
          for(j=0;j<=n;j++){      //--------------(3)
              for(k=0;j+k<=n;k+=i){     //-------------(4)
               c2[j+k]+=c1[j];
             }
          }
              for(j=0;j<=n;j++){         //-------------(5)
                    c1[j]=c2[j];
                    c2[j]=0;           
              }
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}
 
讲解:① 、首先对c1初始化,由第一个表达式(1+x+x2+..xn)初始化,把质量从0到n的所有数都初始化为1.
 ② 、 i从2到n遍历,这里i就是指第i个表达式,上面给出的第二种母函数关系式里,每一个括号括起来的就是一个表达式。 
③、j 从0到n遍历,这里j就是(前面i個表達式累乘的表達式)里第j个变量。如(1+x)(1+x^2)(1+x^3),j先指示的是1和x的系数,i=2执行完之后变为  (1+x+x^2+x^3)(1+x^3),这时候j应该指示的是合并后的第一个括号的四个变量的系数。.  
④ 、 k表示的是第j个指数,所以k每次增i(因为第i个表达式的增量是i)。
⑤ 、把c2的值赋给c1,而把c2初始化为0,因为c2每次是从一个表达式中开始的 
 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值