hdu 1081 to be max

39 篇文章 0 订阅
35 篇文章 0 订阅
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
 


算法:最小子列和比较简单,二维问题可以通过枚举一个i,j降为一维问题。

代码:


#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <string.h>
using namespace std;

int dp[110];

int m[110][110];
int PreSum[110][110];
int ary[110];
int n;

int Result;

bool Input();
void Caculate();
int GetDp();

int main(){
	while(cin>>n){
		Input();
		Caculate();
		cout<<Result<<endl;
	}
}

bool Input(){
	memset(PreSum, 0, sizeof(PreSum));
	for(int i = 0; i < n; ++i){
		for(int j = 1; j <= n; ++j){
			cin>>m[i][j];
			PreSum[i][j] = PreSum[i][j-1] + m[i][j];
		}
	}
	return true;
}

void Caculate(){
	Result = -0x0FFFFFFF;
	for(int i =0; i <= n; ++i){
		for(int j = i + 1; j <= n; ++j){
			for(int l = 0; l < n; ++l){
				ary[l] = PreSum[l][j] - PreSum[l][i];
			}
			Result = max(Result, GetDp());
		}
	}
}

int GetDp(){
	memset(dp, 0, sizeof(dp));
	dp[0] = ary[0];
	for(int i = 1; i < n; ++i){
		dp[i] = max(dp[i-1] + ary[i], ary[i]);
	}
	return *max_element(dp, dp + n);
}
结果:

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
158223022015-12-11 21:45:43Accepted108131MS1888K963 BC++BossJue


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值