1sting

33 篇文章 0 订阅
4 篇文章 0 订阅

1sting

Time Limit : 5000/1000ms (Java/Other)
Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 36
Accepted Submission(s) : 10

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output
The output contain n lines, each line output the number of result you can get .

Sample Input
3
1
11
11111

Sample Output
1
2
8

思路:这是一道大数题,规律是斐波那契,因为要两个数相加,将这两个数都放到数组中去,因为有l=strlen(s)个数,所以用二维数组记录。

#include<stdio.h>
#include<string.h>
#define max 200
int main()
{
    int i,j,n,len,num[max+20][1000];
    char s[max+20];
    memset(num,0,sizeof(num));
    num[1][1]=1;
    num[2][1]=2;
    for(i=3;i<=max;i++)
    {
        for(j=1;j<1000;j++)
        {   
            num[i][j]+=num[i-1][j]+num[i-2][j];//一定要特别注意这里是+=,因为这里第j位可能有前一位进阶的值**重点内容**
            if(num[i][j]>=10)
            {
                num[i][j]%=10;
                num[i][j+1]+=1;
            }
        }
    }
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",&s);
        len=strlen(s);
        for(i=1000;i>0&&num[len][i]==0;i--);
        for(;i>0;i--)
        printf("%d",num[len][i]);
        printf("\n");   
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值