SDUT OJ 数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Sample Input
abc,,de,g,,f,,,
Sample Output
3

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char c;
    struct node *lt, *rt;
};

char s[100];
int i,k;

struct node *creat()
{
    struct node *root;
    if(s[i]==','){
        i++;
        root=NULL;
    }
    else{
        root=(struct node *)malloc(sizeof(struct node));
        root->c=s[i++];
        root->lt=creat();
        root->rt=creat();
    }
    return root;
}

void num(struct node *root)
{
    if(root){
        if(!root->lt&&!root->rt){
            k++;
        }
        num(root->lt);
        num(root->rt);
    }
}

int main()
{
    while(~scanf("%s",s))
    {
        i=0;k=0;
        struct node *root;
        root=creat();
        num(root);
        printf("%d\n",k);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值