Catalan数得到应用——求解n个结点组成的二叉树的种类


Description

Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging. 
Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements. 

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure. 
 
If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful. 

Input

The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed. 

Output

For each input case print the number of binary trees that can be built using the n elements, followed by a newline character. 

Sample Input

1
2
10
25
0

Sample Output

1
4
60949324800
75414671852339208296275849248768000000


给定N个节点,能构成多少种不同形态的二叉树?能构成h(N)个)
(这个公式的下标是从h(0)=1开始的)

h[i]=(4*i-2)*h[i-1]/(i+1);


不同的二叉树:h[i]=i*(4*i-2)*h[i-1]/(i+1);


#include<cmath>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int num[110][1010];
int main()
{
    num[0][0]=1;
    num[0][1]=1;
    int p=1;
    for(int i=1;i<=100;i++)
    {
        int add=0;
        for(int j=1;j<=p;j++)
        {
            int t=num[i-1][j]*i*(4*i-2)+add;
            add=t/10;
            num[i][j]=t%10;
        }
        while(add)
        {
            num[i][++p]=add%10;
            add=add/10;
        }
        for(int j=p;j>=1;j--)
        {
            int t=num[i][j]+add*10;
            num[i][j]=t/(i+1);
            add=t%(i+1);
        }
        while(!num[i][p])
            p--;
        num[i][0]=p;
    }
    int n;
    while(cin>>n)
    {
        if(n==0)
            return 0;
        for(int i=num[n][0];i>=1;i--)
            cout<<num[n][i];
        cout<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值