K - The Marshtomp has seen it all before HihoCoder - 1082

fjxmlhx不喜欢网上的 marshtomps 。所以他决定把所有的 “marshtomp”(名字不区分大小写) 改为 “fjxmlhx;

Input
输入包含多行,每行字符串不超过200的长度,一个单词不会一半出现在上一行,剩下的在下一行。直到文件结束(EOF)

Output
输出 替换之后的字符串。

Sample Input
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
Sample Output
The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB
这道题我遇到的问题是怎么把 Marshtomp 用 fjxmlhx 给替换掉,检查出这个单词简单,但是问题是如何把他给完整的替换掉,然后上网查找出来的解决方法是建立一个新的字符数组用来保存答案。

#include<iostream>
#include<string>
using namespace std;

int check(int i, string a)
{
    if((a[i]=='M'||a[i]=='m')&&(a[i+1]=='A'||a[i+1]=='a')&&(a[i+2]=='R'||a[i+2]=='r')&&  
        (a[i+3]=='S'||a[i+3]=='s')&&(a[i+4]=='H'||a[i+4]=='h')&&(a[i+5]=='T'||a[i+5]=='t')&&  
        (a[i+6]=='O'||a[i+6]=='o')&&(a[i+7]=='M'||a[i+7]=='m')&&(a[i+8]=='P'||a[i+8]=='p')){  
            return true;  
    }  
    return false;  
}  
int main()
{
    string str;
    string cha = "fjxmlhx";
    while(getline(cin, str))
    {
        string str_1 = "";
        int j = 0;
        for(int i = 0; i < str.size(); i ++)
        {
            if(check(i, str))
            {
                str_1 = str_1 + cha;
                i += 8;
            }
            else str_1 = str_1 + str[i];
        }
        cout << str_1 << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值