kuangbin带你飞专题一(搜索)B - Dungeon Master

上题:

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
思路:
一个简单的三维地图,直接bfs套模板就好了,出题的目的只是纯粹为了练手速吗?
但是自己再写的时候还是有些小瑕疵在里面,感觉自己的参数设置的不好,导致自己的can_go函数写的有问题,自己一直在找bug,还有就是自己没有清空队列,交了一发worng,类似的问题还有vis数组没有memset这些都是以后需要注意的地方啊!!!!
#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
char map[40][40][40];
int vis[100][100][100];
int movex[6]={1,-1,0,0,0,0};
int movey[6]={0,0,1,-1,0,0};
int movez[6]={0,0,0,0,1,-1};
struct node
{
	int x,y,z;
	int stept;
	friend bool operator <(const node &a,const node &b)
	{
		 a.stept>b.stept;
	}
};
int L,R,C;
int sz,sx,sy,ez,ex,ey;
int can_go(int z,int x,int y)
{
	if(z<0||z>=L||x<0||x>=R||y<0||y>=C||map[z][x][y]=='#')
	{
		return 0;
	}
	return 1;
}
queue<node>que;
int bfs()
{
	memset(vis,0,sizeof(vis));
	node now,next;
	now.x=sx;
	now.y=sy;
	now.z=sz;
	vis[sz][sx][sy]=1;
	now.stept=0;
	que.push(now);
	while(!que.empty())
	{
		now=que.front();
		que.pop();
		if(now.z==ez&&now.x==ex&&now.y==ey)
		{
			return now.stept;
		}
		for(int i=0;i<6;i++)
		{
			next.z=now.z+movez[i];
			next.x=now.x+movex[i];
			next.y=now.y+movey[i];
			if(can_go(next.z,next.x,next.y)&&!vis[next.z][next.x][next.y])
			{
				vis[next.z][next.x][next.y]=1;
				next.stept=now.stept+1;
				que.push(next);
			}	
		}
	}
	return -1;
}
int main()
{
	while(scanf("%d%d%d",&L,&R,&C),L||R||C)
	{
		while(!que.empty()) 
		{
			que.pop();
		}
		for(int i=0;i<L;i++)
		{
			for(int j=0;j<R;j++)
			{
				scanf("%s",map[i][j]);
				for(int k=0;k<C;k++)
				{
					if(map[i][j][k]=='S')
					{
						sz=i;
						sx=j;
				        sy=k;
					}
					if(map[i][j][k]=='E')
					{
						ez=i;
						ex=j;
						ey=k;
					}
				}
			}
		}
		int ans=bfs();
		if(ans==-1)
		{
			printf("Trapped!\n");
		}
		else 
		{
			printf("Escaped in %d minute(s).\n",ans);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值