上题:
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects. Input
Output
Sample Input
Sample Output
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects. Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
For each case, output the number of suspects in one line.
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
4 1 1
大致的题意就是:
现在给你n个100 之中有m个团体,其实团体中有0的表示是感染者 ,感染者可以感染团体中的所有人,并让他们也成为感染者,思路就是简单的并查集,但是输入格式很gay,没有想到。。。解决方法就是先输入一个数字,之后把第一个数字和之后的k-1个人并在一起,还有个需要注意的情况就是 我们这样并上去其实是没有办法找到和0有关的人因为他是这样的,所以我们要找到所有和0有的数字的话是要利用 getf(0)==getf(i)这种方式,利用根节点去便利,现在上代码:
#include<stdio.h>
int p[40000];
int getf(int x)
{
return x==p[x]?x:p[x]=getf(p[x]);
}
void join(int x,int y)
{
int dx=getf(x);
int dy=getf(y);
if(dx!=dy)
{
p[dx]=dy;
}
}
int main()
{
int n,t;
while(scanf("%d%d",&n,&t),n||t)
{
int sum=0;
for(int i=0;i<=n;i++)
{
p[i]=i;
}
while(t--)
{
int a,b,m;
scanf("%d",&m);
// if(m>=1)
{
scanf("%d",&a);
for(int i=0;i<m-1;i++)
{
scanf("%d",&b);
join(a,b);
}
}
}
for(int i=0;i<n;i++)
{
if(getf(0)==getf(i))
{
sum++;
}
}
printf("%d\n",sum);
}
}