NYOJ 927 The partial sum problem(深搜)

描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can't!
题意就是 给你几个数 和一个值,问你能从这几个数的和中找到这个值,思路就是简单的深搜,看代码吧,代码讲的很清楚:
#include<stdio.h>
#include<string.h>
int a[25],n,t;
int vis[25];
int flag=0;
int sum=0;//sum全局变量,深搜的值 
void dfs(int cur)
{	
//	printf("sum==%d  cur=%d\n",sum,cur);
	if(sum==t)
	{
		flag=1;
		return ;
	}
	if(flag)
	{
		return ;
	}
/*	if(vis[cur])
	{
		return ;
	}*/
	if(cur>=n)
	{
		return ;
	}
	if(sum<0)
	{
		return ;
	}
	if(sum>t)//如果超过t的时候就return 
	{
		return ;
	}
	for(int i=cur;i<n;i++)
	{
		if(!vis[i])
		{
			vis[i]=1;
			sum+=a[i];
			dfs(i);
			vis[i]=0; //回溯 
			sum-=a[i];//减去这个值 
		//	printf("a[%d]=%d sum=%d\n",i,a[i],sum);
		}
	}
	return ;
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(vis,0,sizeof(vis));
		memset(a,0,sizeof(a));
		flag=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		scanf("%d",&t);
		dfs(0);
		if(flag)
		{
			printf("Of course,I can!\n");
		}
		else 
		{
			printf("Sorry,I can't!\n");
		}
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值