HDU 2136 Largest prime factor

http://acm.hdu.edu.cn/showproblem.php?pid=2136

 

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2815    Accepted Submission(s): 993


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 


 

Input
Each line will contain one integer n(0 < n < 1000000).
 


 

Output
Output the LPF(n).
 


 

Sample Input
1 2 3 4 5
 


 

Sample Output
0 1 2 1 3
 


 

Author
Wiskey
 


 

Source
 


 

Recommend
威士忌
 
题意:给一个数,求它的最大质因子在素数中的排名。1为0,2为1,3为2……
分析:用哈希打表的方法搞定
代码如下:
#include<stdio.h>
#include<string.h>
int biao[1000001];
void fun()
{
  int i,j,k=1;
  memset(biao,0,sizeof(biao));
  for(i=2;i<1000000;i++)
  {
    if(biao[i]==0)
        {
        for(j=1;i*j<999999;j++)
              biao[i*j]=k;
              k++;
        }
  }
  biao[1]=0;
}
int main()
{
  int n;
  fun();
  while(scanf("%d",&n)!=EOF)
  {
    printf("%d\n",biao[n]);
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值