HDU 1977 Consecutive sum II

http://acm.hdu.edu.cn/showproblem.php?pid=1977

 

Consecutive sum II

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 894    Accepted Submission(s): 453


Problem Description
Consecutive sum come again. Are you ready? Go ~~
      = 0 + 1
2+3+4        = 1 + 8
5+6+7+8+9    = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.
 


 

Input
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 2100000).
 


 

Output
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.
 


 

Sample Input
3 0 1 2
 


 

Sample Output
0 1 1 8 8 27
 


 

Author
Wiskey
 


 

Source
 


 

Recommend
wangye
 
分析:找规律。
      我找的规律:每一行左边共n^2+1个数,每行第一个数为2n+1,这样通过等差数列求和,化简可以得到:这一行左边加起来等于2*i*i*i+3*i*i+3*i+1.
    用数组biao[2100000]储存该数,按照题中的输出要求,给biao[]赋值时:biao[i]=2*i*i*i+3*i*i+3*i+1-biao[i-1].给定n,输出biao[n-1] biao[n]\n即可。
    我自己找的规律其实非常麻烦,在网上看到给定n,m=n+1,输出n*n*n m*m*m\n即可。原来规律是这个。。完全没有发现啊 (⊙o⊙)
 
代码如下:
(1)按我找的规律写的:
#include<stdio.h>
#include<string.h>
long long biao[2100010];
void fun()
{
  memset(biao,0,sizeof(biao));
  __int64 i;
  biao[0]=1;
  for(i=1;i<2100010;i++)
        biao[i]=2*i*i*i+3*i*i+3*i+1-biao[i-1];
}
int main()
{
  int T,n;
  fun();
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d",&n);
    if(n==0) printf("0 1\n");
    else printf("%I64d %I64d\n",biao[n-1],biao[n]);
  }
  return 0;
}
(2)网上看到的 转载自: yzy杨子衍
#include <stdio.h>
int main ()
{
__int64 n,t,m;
scanf("%I64d",&t);
while (t--)
{
    scanf("%I64d",&n);
    m=n+1;
    printf("%I64d %I64d\n",n*n*n,m*m*m);
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值