HDU 1164 Eddy's research I

http://acm.hdu.edu.cn/showproblem.php?pid=1164

 

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3255 Accepted Submission(s): 1994


Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .


 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.


 

Output
You have to print a line in the output for each entry with the answer to the previous question.


 

Sample Input
11 9412


 

Sample Output
11 2*2*13*181


 

Author
eddy


 

Recommend
JGShining
 
分析:素数用哈希打表记录,遍历所有素数判断能否除尽,若能除尽则记录,最后输出。但是要注意,如果能除尽,记录后这个素数还要再次判断。如题目中给出的例子中,9412的因子中有两个2.
代码如下:
#include<stdio.h>
#include<string.h>
int prime[65536];
void fun()
{
 int i,j;
 memset(prime,1,sizeof(prime));
 for(i=2;i<65536;i++)
    for(j=2;i*j<65536;j++)
         if(prime[i])
   prime[i*j]=0;
   prime[0]=prime[1]=0;
}
int main()
{
 fun();
 int ans[60000];
 int i,j;
 int w,count;
 while(scanf("%d",&w)==1)
 {
  count=0;
 for(i=65535;i>0;i--)
    {
       if(prime[i])
          if(w%i==0)
             {
       ans[count++]=i;
       w/=i;
       i++;
             }
     }
     printf("%d",ans[count-1]);
     for(i=count-2;i>=0;i--)
       printf("*%d",ans[i]);
       printf("\n");
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值