杭电1042

        一道大数阶乘的题,刚开始写了个程序,tle,,,后来稍微优化了一下,跑了1500多ms,,,据说还可以优化很多,,算法真的是博大精深啊。。。题目:

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 
Input
One N in one line, process to the end of file.
Output
For each N, output N! in one line.
 


 

Sample Input
  
  
1 2 3
 


 

Sample Output
  
  
1 2 6


 

ac代码:

#include <iostream>
using namespace std;
int main()
{
  int n;
  while(cin>>n)
  {
	  int a[50000]={0},i,j,digit=1;
	  a[0]=1;
	  for(i=2;i<=n;++i)
	  {
	    int count;
		for(j=1,count=0;j<=digit;++j)
		{
		  int s=a[j-1]*i+count;
		  a[j-1]=s%10;
		  count=s/10;
		}
		while(count)
		{
		  a[++digit-1]=count%10;
		  count/=10;
		}
	  }
	  for(i=digit;i>=1;i--)
	  {
	    cout<<a[i-1];
	  }
	  
	  cout<<endl;
  }
  return 0;
}

我再看看还能怎么优化

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值