这真是一道悲催的题,本来对字典树都是入门阶段,,又碰到这么一道BT的题,悲剧。。。想这道题想了好久,好不容易想出来怎么做,没想到又MLE了,气得半死。怎么也想不出来怎么优化内存,后来问了位学长,才知道每次都可以释放内存,,,,囧,,这次算是长见识了,以前根本不知道还可以释放内存,,,,学习了。题目:
Phone List
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3511 Accepted Submission(s): 1174
Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
Sample Output
NO YES
#include <iostream>
#include <cstdio>
#include <string.h>
#include <malloc.h>
#include <string>
using namespace std;
struct Tire{
int n;
struct Tire *tire[10];
}*a;
void init(){
a=(Tire*)malloc(sizeof(Tire));
for(int i=0;i<10;++i)
a->tire[i]=NULL;
a->n=0;
}
bool insert(char s[]){
int len=strlen(s);
Tire *head=a;
for(int i=0;i<len;++i){
int k=s[i]-'0';
if(head->tire[k]==NULL){
if(i==len-1)
head->n=2;
else
head->n=1;
head->tire[k]=new Tire;
head=head->tire[k];
for(int i=0;i<10;++i)
head->tire[i]=NULL;
}
else{
if(head->n==2)
return false;
head=head->tire[k];
}
}
for(int i=0;i<10;++i)
{
if(head->tire[i]!=NULL)
return false;
}
return true;
}
void del(Tire *root){
for(int i=0;i<10;++i){
if(root->tire[i]!=NULL)
del(root->tire[i]);
delete root->tire[i];
}
}
int main(){
int num;
scanf("%d",&num);
while(num--){
init();
int count;
scanf("%d",&count);
bool flag=true;
char ss[10];
while(count--){
scanf("%s",ss);
if(!flag)
continue;
flag=insert(ss);
}
if(flag)
printf("YES\n");
else
printf("NO\n");
del(a);
}
return 0;
}