这道题题意有点晦涩,读了很久才明白。结果提交确实wa,,让我一度怀疑自己理解错题意了,后来又仔细看了看程序,发现了一个bug,改过后就ac了。题意就是求n个数的前k个,但是还有另一个属性序号,序号从小到大排序即可。题目:
Design T-Shirt
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2173 Accepted Submission(s): 1080
Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
Sample Input
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
Sample Output
6 5 3 1 2 1
ac代码:
#include <iostream>
#include <string.h>
#include <algorithm>
#include <cmath>
using namespace std;
const int N=10005;
#define mmin 1e-10
struct digit{
double num;
int xuhao;
}aa[N];
bool cmp1(digit a,digit b){
if(fabs(a.num-b.num)<0.000001)
return a.xuhao<b.xuhao;
return a.num>b.num;
}
bool cmp2(digit a,digit b){
return a.xuhao>b.xuhao;
}
int main(){
//freopen("11.txt","r",stdin);
int n,m,k;
while(~scanf("%d%d%d",&n,&m,&k)){
double x;
for(int i=0;i<m;++i){
aa[i].num=0.0;
}
for(int j=0;j<n;++j){
for(int i=0;i<m;++i){
scanf("%lf",&x);
aa[i].num+=x;
}
}
for(int i=0;i<m;++i)
aa[i].xuhao=i+1;
sort(aa,aa+m,cmp1);
sort(aa,aa+k,cmp2);
for(int i=0;i<k-1;++i)
printf("%d ",aa[i].xuhao);
printf("%d",aa[k-1].xuhao);
printf("\n");
}
return 0;
}