1025 PAT Ranking

1025 PAT Ranking

题目:

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

struct stu {
	char id[15];  //学号
	int score;  //分数
	int location_number;   //考场号
	int local_rank;   //本考场的排名
}s[30000];

bool cmp(stu s1, stu s2) {
	if (s1.score != s2.score)
		return s1.score > s2.score;// 先按照分数从高到低排序
	else   //分数相同按照准考证 号从小到大排序
		return strcmp(s1.id, s2.id) < 0;
}

int main() {
	int n;
	scanf("%d", &n);
	int num = 0;//num为考生的总数,因为所有的考生都在一个数组中,所以num也可以用来帮助定位
	for (int i = 0; i < n; i++) {
		int k;
		scanf("%d", &k);
		
		for (int j = 0; j < k; j++) {
			scanf("%s %d", s[num].id, &s[num].score);//注意加&符号
			s[num].location_number = i + 1;   //改考生的考场号为i+1
			num++;//考生人数增加
		}
		sort(s+num-k, s + num, cmp);   //将该考场的考生排序
		//注意这里:这个考场的考生所对应的数组下标就是区间[num-k,num)
		s[num - k].local_rank = 1;//该考场的第一名的local_rank为1
		for (int j = num - k + 1; j < num; j++) {
			if (s[j].score == s[j - 1].score) {
				//如果与前一位考生同分数
				s[j].local_rank = s[j - 1].local_rank;
			}
			else {
				//如果与前一位考生不同分
				//local_rank为该考生在这一考场前面的人数
				s[j].local_rank = j + 1 - (num - k);
			}
		}
	}
	printf("%d\n", num);//输出考生的总数
	sort(s, s + num, cmp);//将所有的考生排序
	int r = 1;//当前考生的排名
	for (int i = 0; i < num; i++) {
		if (i > 0 && s[i].score != s[i - 1].score) {
			r = i + 1;
			//当前考生与上一个考生分数不同的时候,让r更新为人数+1
		}
		printf("%s ", s[i].id);
		printf("%d %d %d\n", r, s[i].location_number, s[i].local_rank);
	}
}

在这里插入图片描述
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值