nyoj Radar

描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
贪心算法,先将所有的点转化成区间,
对区间左点排序,比较。。。
代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct readar{
	double left;
	double right;
}s[1500];
bool cmp(readar x,readar y){
	if(x.right<y.right)
	   return true;
	return false;
} 
int main(){
	int n;
	double a,r,b;
	int i,j,k;
	double num,t;
	int cas=1;
	while(~scanf("%d%lf",&n,&r),n!=0&&r!=0){
		int flag=0;
		for(i=0;i<n;i++){
			scanf("%lf%lf",&a,&b);
			if(r<b){
				flag=1;
				continue;
			}
			num=sqrt(r*r-b*b);
			s[i].left=a-num;
			s[i].right=a+num;
			}
			
			sort(s,s+n,cmp);
			int ans=1;
			t=s[0].right;
			for(i=1;i<n;i++){
				if(s[i].left>t)
				{
					ans++;
					t=s[i].right;
				}
			} 
			if(flag)
				printf("Case %d: -1\n",cas++);
			else
			printf("Case %d: %d\n",cas++,ans);
		} 
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值