NYOJ Radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
题意 : 海上有许多小岛建立直角坐标系在x轴上安装雷达用最少的雷达把岛屿全都覆盖给出各岛坐标和雷达覆盖半径如果不能覆盖输出-1
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct	Node{
		int x,y;
		double d;
}A[1010];
bool	cmp(Node a,Node b){
		return a.d<b.d;
}
int main()
{
	int i,n,d,sign,ans,t=1;
	double x,l;
	while(scanf("%d%d",&n,&d)==2){
		if(n==0&&d==0)break;
		sign=0;
		for(i=0;i<n;++i){
			scanf("%d%d",&A[i].x,&A[i].y);
			if(A[i].y>d)sign=1;
			A[i].d=A[i].x+sqrt(d*d-(A[i].y)*(A[i].y));
		}
		if(sign==1){
			printf("-1\n");continue;
		}
		stable_sort(A,A+n,cmp);
		x=A[0].d;ans=1;
		for(i=1;i<n;++i){
			l=sqrt(((A[i].x)-x)*((A[i].x)-x)+(A[i].y)*(A[i].y));
			if(l>d){
				ans++;
				x=A[i].d;
			}
		}
		printf("Case %d: %d\n",t++,ans);
	}
	return 0;
}        
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值