南阳理工ACM-题目5-Binary String Matching

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
#include<stdio.h>
#include<string.h>
int main()
{
	int x,n=0,i=0,j=0,s=0,la,lb;char a[10],b[1000];
	scanf("%d",&x);fflush(stdin);
	while(x--)
	{
		memset(a,'0',sizeof(a));
		memset(b,'0',sizeof(b));
		scanf("%s",a);
		scanf("%s",b);
		la=strlen(a);
		lb=strlen(b);
		while(i<lb)
		{
			if(b[i]==a[j])
			{	
				i++;j++;
				if(j==la)
				{s++;j=0;i=i-(la-1);} 
			}
			else 
			{i=i-j+1;j=0;
//			printf("%c\n",b[i]);printf("%c\n",a[j]);
			}
		}
		
		printf("%d\n",s);
		s=0;i=0;j=0;
	}
} 

#include <stdio.h>
#include <string.h>
int main()
{
	int n,m;
	int i,j;
	int n1,l1,l2;
	char a[15],b[1005];
	int sum;
	scanf("%d",&n);
	while(n--)
	{
		memset(a,'0',sizeof(a));
		memset(b,'0',sizeof(b));
		scanf("%s",a);
		scanf("%s",b);
		l1=strlen(a);
		l2=strlen(b);.
		sum=0;
		for(i=0;i<=l2-l1;i++)
		{
			n1=0;
			for(j=0;j<l1;j++)
			{
				if(a[j]==b[i+j])
					n1++;
				else
					break;
			}
			if(n1==l1)
			sum++;
		}
			printf("%d\n",sum);
 
	}
	return 0;
}

//优秀代码
 
#include<iostream>
#include<string>
using namespace std;
int main()
{
	string s1,s2;
	int n;
	cin>>n;
	while(n--)
	{
		cin>>s1>>s2;
		unsigned int m=s2.find(s1,0);
		int num=0;
		while(m!=string::npos)
		{
			num++;
			m=s2.find(s1,m+1);
		}
		cout<<num<<endl;
	}
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值